Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in quagga
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in quagga
ID: openSUSE-SU-2018:0473-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mo, 19. Februar 2018, 16:39
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5379
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16227
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5381
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5380
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5378
Applikationen: quagga

Originalnachricht

   openSUSE Security Update: Security update for quagga
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0473-1
Rating: important
References: #1065641 #1079798 #1079799 #1079800 #1079801

Cross-References: CVE-2017-16227 CVE-2018-5378 CVE-2018-5379
CVE-2018-5380 CVE-2018-5381
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for quagga fixes the following issues:

- CVE-2017-16227: Fixed bgpd DoS via specially crafted BGP UPDATE messages
(boo#1065641)
- CVE-2018-5378: Fixed bgpd bounds check issue via attribute length
(Quagga-2018-0543,boo#1079798)
- CVE-2018-5379: Fixed bgpd double free when processing UPDATE message
(Quagga-2018-1114,boo#1079799)
- CVE-2018-5380: Fixed bgpd code-to-string conversion tables overrun
(Quagga-2018-1550,boo#1079800)
- CVE-2018-5381: Fixed bgpd infinite loop on certain invalid OPEN messages
(Quagga-2018-1975,boo#1079801)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-177=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libfpm_pb0-1.1.1-18.3.1
libfpm_pb0-debuginfo-1.1.1-18.3.1
libospf0-1.1.1-18.3.1
libospf0-debuginfo-1.1.1-18.3.1
libospfapiclient0-1.1.1-18.3.1
libospfapiclient0-debuginfo-1.1.1-18.3.1
libquagga_pb0-1.1.1-18.3.1
libquagga_pb0-debuginfo-1.1.1-18.3.1
libzebra1-1.1.1-18.3.1
libzebra1-debuginfo-1.1.1-18.3.1
quagga-1.1.1-18.3.1
quagga-debuginfo-1.1.1-18.3.1
quagga-debugsource-1.1.1-18.3.1
quagga-devel-1.1.1-18.3.1


References:

https://www.suse.com/security/cve/CVE-2017-16227.html
https://www.suse.com/security/cve/CVE-2018-5378.html
https://www.suse.com/security/cve/CVE-2018-5379.html
https://www.suse.com/security/cve/CVE-2018-5380.html
https://www.suse.com/security/cve/CVE-2018-5381.html
https://bugzilla.suse.com/1065641
https://bugzilla.suse.com/1079798
https://bugzilla.suse.com/1079799
https://bugzilla.suse.com/1079800
https://bugzilla.suse.com/1079801

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung