Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in PHP
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in PHP
ID: USN-3600-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 17.10
Datum: Mo, 19. März 2018, 14:42
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10712
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5712
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7584
Applikationen: PHP

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============0188747704763563717==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="z4IkSdU8XjN0jLBve8uFTIerG2PVKv0nP"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--z4IkSdU8XjN0jLBve8uFTIerG2PVKv0nP
Content-Type: multipart/mixed;
boundary="7U3hu5rTTTsV4yd42SnsLxh1QDAK1alp0";
protected-headers="v1"
From: Marc Deslauriers <marc.deslauriers@canonical.com>
Reply-To: Ubuntu Security <security@ubuntu.com>
To: ubuntu-security-announce@lists.ubuntu.com
Message-ID: <27eb455b-492b-c206-1d45-df2575fc1da8@canonical.com>
Subject: [USN-3600-1] PHP vulnerabilities

--7U3hu5rTTTsV4yd42SnsLxh1QDAK1alp0
Content-Type: text/plain; charset=utf-8
Content-Language: en-C
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3600-1
March 19, 2018

php5, php7.0, php7.1 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in PHP.

Software Description:
- php7.1: HTML-embedded scripting language interpreter
- php7.0: HTML-embedded scripting language interpreter
- php5: HTML-embedded scripting language interpreter

Details:

It was discovered that PHP incorrectly handled certain stream metadata. A
remote attacker could possibly use this issue to set arbitrary metadata.
This issue only affected Ubuntu 14.04 LTS. (CVE-2016-10712)

It was discovered that PHP incorrectly handled the PHAR 404 error page. A
remote attacker could possibly use this issue to conduct cross-site
scripting (XSS) attacks. This issue only affected Ubuntu 16.04 LTS and
Ubuntu 17.10. (CVE-2018-5712)

It was discovered that PHP incorrectly handled parsing certain HTTP
responses. A remote attacker could use this issue to cause PHP to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2018-7584)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
libapache2-mod-php7.1 7.1.15-0ubuntu0.17.10.1
php7.1-cgi 7.1.15-0ubuntu0.17.10.1
php7.1-cli 7.1.15-0ubuntu0.17.10.1
php7.1-fpm 7.1.15-0ubuntu0.17.10.1

Ubuntu 16.04 LTS:
libapache2-mod-php7.0 7.0.28-0ubuntu0.16.04.1
php7.0-cgi 7.0.28-0ubuntu0.16.04.1
php7.0-cli 7.0.28-0ubuntu0.16.04.1
php7.0-fpm 7.0.28-0ubuntu0.16.04.1

Ubuntu 14.04 LTS:
libapache2-mod-php5 5.5.9+dfsg-1ubuntu4.24
php5-cgi 5.5.9+dfsg-1ubuntu4.24
php5-cli 5.5.9+dfsg-1ubuntu4.24
php5-fpm 5.5.9+dfsg-1ubuntu4.24

In Ubuntu 16.04 LTS and Ubuntu 17.10, this update uses a new upstream
release, which includes additional bug fixes.

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3600-1
CVE-2016-10712, CVE-2018-5712, CVE-2018-7584

Package Information:
https://launchpad.net/ubuntu/+source/php7.1/7.1.15-0ubuntu0.17.10.1
https://launchpad.net/ubuntu/+source/php7.0/7.0.28-0ubuntu0.16.04.1
https://launchpad.net/ubuntu/+source/php5/5.5.9+dfsg-1ubuntu4.24


--7U3hu5rTTTsV4yd42SnsLxh1QDAK1alp0--

--z4IkSdU8XjN0jLBve8uFTIerG2PVKv0nP
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJar7aFAAoJEGVp2FWnRL6Tb6oQALTC4PfOuy9oXRNuPRP1zbVf
2FC0HJ1ds7M+PrZYNVvmbmMb2YNhB8HnwZ9xDKr34c5D/J4AjbtQxWtAjUpp3/EE
W32K2p++meNqTG7BQ8kc1KGciCn0odgZRDIIRN9zm6p2OEUAxWAFiFtqySxkuKTV
GlYblKo0Bsty0jo59M5wLmCDtFQD5ZIvzmFIP83DL0CZq32ltemlLNFdejrbaaRo
DRrJgPF+JUU9xjZ0oUDs+V1s/y8z5f4Ii19lqy/L/0ed3buv8dP/Wuof9gUiGGPn
5wrpELy4uzoIZuNJfPoXGpb7EdB1074MVVnLxmnNpXs5p4tMc0b0JefE8mS+sufJ
H3KtT8o2272gIOqZz7jSABewXgKJ0VTM03JHLgVleDbUOspVsZnIPYAphQRakO0z
ktRwMPee2nh8bJwoTJeLAYR59eBdkM84+7K7chgGXYD1dyIT7Bk+pUni+Xjq+Zkx
JBLCWoaBwv+kX5iYzaVKnerCpwfJyKqiKHtghEnI+ilRNnPIfy+qhJ3kE2hfrp57
xtZGKfor7PHk6NYb3htDPdOtqiHmvKB1VaXdS5kwxBkQoguTeJJC9IObua1CSF9L
giKYgAyvrckuiBuuhHuNlumSXQqtLit+EbrdFGxHfqRTCvTuX9cLhEkZrjne9DOs
Jmiaf+Yz8uj9Ymje6nXf
=/N7G
-----END PGP SIGNATURE-----

--z4IkSdU8XjN0jLBve8uFTIerG2PVKv0nP--


--===============0188747704763563717==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============0188747704763563717==--
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung