Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in LibVNCServer
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in LibVNCServer
ID: openSUSE-SU-2018:0851-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Fr, 30. März 2018, 08:47
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7225
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9942
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9941
Applikationen: LibVNCServer

Originalnachricht

   openSUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0851-1
Rating: important
References: #1017711 #1017712 #1081493
Cross-References: CVE-2016-9941 CVE-2016-9942 CVE-2018-7225

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

LibVNCServer was updated to fix two security issues.

These security issues were fixed:

- CVE-2018-7225: Missing input sanitization inside rfbserver.c
rfbProcessClientNormalMessage() (bsc#1081493).
- CVE-2016-9942: Heap-based buffer overflow in ultra.c allowed remote
servers to cause a denial of service (application crash) or possibly
execute arbitrary code via a crafted FramebufferUpdate message with the
Ultra type tile, such that the LZO payload decompressed length exceeds
what is specified by the tile dimensions (bsc#1017712).
- CVE-2016-9941: Heap-based buffer overflow in rfbproto.c allowed remote
servers to cause a denial of service (application crash) or possibly
execute arbitrary code via a crafted FramebufferUpdate message
containing a subrectangle outside of the client drawing area
(bsc#1017711).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-326=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

LibVNCServer-debugsource-0.9.9-16.3.1
LibVNCServer-devel-0.9.9-16.3.1
libvncclient0-0.9.9-16.3.1
libvncclient0-debuginfo-0.9.9-16.3.1
libvncserver0-0.9.9-16.3.1
libvncserver0-debuginfo-0.9.9-16.3.1
linuxvnc-0.9.9-16.3.1
linuxvnc-debuginfo-0.9.9-16.3.1


References:

https://www.suse.com/security/cve/CVE-2016-9941.html
https://www.suse.com/security/cve/CVE-2016-9942.html
https://www.suse.com/security/cve/CVE-2018-7225.html
https://bugzilla.suse.com/1017711
https://bugzilla.suse.com/1017712
https://bugzilla.suse.com/1081493

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung