Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in LibRaw
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in LibRaw
ID: USN-3615-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 17.10
Datum: Di, 3. April 2018, 23:15
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5800
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16909
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5802
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16910
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5801
Applikationen: LibRaw

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============6337103661279728323==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="V7DDPGl8WEDtUk6KbmPam1Ue8p7fsSk2s"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--V7DDPGl8WEDtUk6KbmPam1Ue8p7fsSk2s
Content-Type: multipart/mixed;
boundary="5cmzqf3QW3To5afoVOrPvqfEl6GHaw1t5";
protected-headers="v1"
From: Marc Deslauriers <marc.deslauriers@canonical.com>
Reply-To: Ubuntu Security <security@ubuntu.com>
To: ubuntu-security-announce@lists.ubuntu.com
Message-ID: <d286a3dc-1552-a069-e969-81744afdd692@canonical.com>
Subject: [USN-3615-1] LibRaw vulnerabilities

--5cmzqf3QW3To5afoVOrPvqfEl6GHaw1t5
Content-Type: text/plain; charset=utf-8
Content-Language: en-C
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3615-1
April 03, 2018

libraw vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

LibRaw could be made to crash or run programs as your login if it opened a
specially crafted file.

Software Description:
- libraw: raw image decoder library

Details:

It was discovered that LibRaw incorrectly handled photo files. If a user or
automated system were tricked into processing a specially crafted photo
file, a remote attacker could cause applications linked against LibRaw to
crash, resulting in a denial of service, or possibly execute arbitrary
code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
libraw16 0.18.2-2ubuntu0.2

Ubuntu 16.04 LTS:
libraw15 0.17.1-1ubuntu0.2

Ubuntu 14.04 LTS:
libraw9 0.15.4-1ubuntu0.2

After a standard system update you need to restart your session to make
all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3615-1
CVE-2017-16909, CVE-2017-16910, CVE-2018-5800, CVE-2018-5801,
CVE-2018-5802

Package Information:
https://launchpad.net/ubuntu/+source/libraw/0.18.2-2ubuntu0.2
https://launchpad.net/ubuntu/+source/libraw/0.17.1-1ubuntu0.2
https://launchpad.net/ubuntu/+source/libraw/0.15.4-1ubuntu0.2


--5cmzqf3QW3To5afoVOrPvqfEl6GHaw1t5--

--V7DDPGl8WEDtUk6KbmPam1Ue8p7fsSk2s
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJaw9qAAAoJEGVp2FWnRL6TlncP/0NyrFGbInWEzdoCzAPICCeI
wtqaePhJ3HVbmT5vEnmEDwBvU4gMxxKRoERQg834dis+N4jZw8okzaIrWm+gnNSP
IyrhsHGDtqT14gVaNIuwIE//7txinhsbOks/5PFjBVYgTWt9u2qly0ZmZmqXEpTu
cTwhpXdkcusZZJDxV9u0dmL/mITA4CmQAN5Q9Ll02/+uiD+IBM8nIk62FTRlsF0t
5Y2HFOXTM9gZvjA1uw0zk9qQ7Nir20HI70CBB67fFEOcekORfi4DUAExRmYPiQ8b
ZUzabgR/gVdbnsbKkyqm09vcYb1QfxkzUgHqfu3UYEGbi+jox6mNIdiRvmEI/bBL
URvmFhADTGLySowKfDv4pGAyGnC+tJIegC7zJl1ZfJKtlwpcYomEiiUc1/auykW2
0BwdkF0lVFQlXGsmnoNagNjAOO/pV1azsvL3wASQ75SK7ybb5KQcgUwWdl5rTBmp
/5s2YpDGZq/qPafbvZM+Zv6aZLA2vnsRbBw69IdBmwtxMTV7/6UT9EdjH27ll25C
LykPOBDkfYdswHF7uf8ropWNSU3JURXdkiD2tl0AndSSq6ky3E6N9KewBJLcBfeE
iA2AagNj15f+MGiPeQnaS7dESY3O+wphcOOY1bvaI4WXAO3rUqzeVZ/1Xs3xP6wW
4GWKB85grpoK/EX/yav/
=v3TT
-----END PGP SIGNATURE-----

--V7DDPGl8WEDtUk6KbmPam1Ue8p7fsSk2s--


--===============6337103661279728323==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============6337103661279728323==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung