Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in The XSLT C library for GNOME
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in The XSLT C library for GNOME
ID: 201804-01
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 4. April 2018, 07:33
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2017-5029
https://nvd.nist.gov/vuln/detail/CVE-2016-4738
Applikationen: The XSLT C library for GNOME

Originalnachricht


--sdtB3X0nJg68CQEu
Content-Type: text/plain; charset=utf-8
Content-Disposition: inlin
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201804-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libxslt: Multiple vulnerabilities
Date: April 04, 2018
Bugs: #598204, #612194
ID: 201804-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were discovered in libxslt, the worst of which
may allow a remote attacker to execute arbitrary code.

Background
==========

libxslt is the XSLT C library developed for the GNOME project. XSLT is
an XML language to define transformations for XML.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libxslt < 1.1.30 >= 1.1.30

Description
===========

Multiple vulnerabilities have been discovered in libxslt. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker, via a crafted HTML page, could possibly execute
arbitrary code, cause a Denial of Service condition or leak
information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxslt users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libxslt-1.1.30"

References
==========

[ 1 ] CVE-2016-4738
https://nvd.nist.gov/vuln/detail/CVE-2016-4738
[ 2 ] CVE-2017-5029
https://nvd.nist.gov/vuln/detail/CVE-2017-5029

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201804-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

--sdtB3X0nJg68CQEu
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAlrEL9gACgkQpRQw84X1
dt1vMgf/YashytbGo5jIi6XhW287BHZOE2+U/jRk5pPEF+/PgFaPo1mXKdGK6876
IB3B3TZMytnewjxCk9yc7xhmI7JOJBOk/hHHIh2ebZxv+4K5L0mWuE6Ds24F2I4P
aLxbdiQql5mPlIIl1zKg6lDZ7wXQMtWnKSFrwgtF1aOW7eOugbts/MXfV9m0kEGd
jyuMZJM0XYdpr7IRfWAXUNbkhf2jy7e9XQTS+m7U3U77pCecXFS7oc3x30p4KTPW
cZ6ZOXuTL5WTrSXJ/Jg2QJCR7lRCmfSUA323B6GHe2Hn2sZkpicmqvXlt0oHokVv
sfJNDF7IoIDE3NtLFWl673VnMP6UAw==
=6cXW
-----END PGP SIGNATURE-----

--sdtB3X0nJg68CQEu--
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung