Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Perl
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Perl
ID: FEDORA-2018-1c8b49fbc7
Distribution: Fedora
Plattformen: Fedora 27
Datum: Sa, 21. April 2018, 12:15
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6913
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6798
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6797
Applikationen: Perl

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2018-1c8b49fbc7
2018-04-21 03:38:52.949252
-------------------------------------------------------------------------------
-

Name : perl
Product : Fedora 27
Version : 5.26.2
Release : 404.fc27
URL : http://www.perl.org/
Summary : Practical Extraction and Report Language
Description :
Perl is a high-level programming language with roots in C, sed, awk and shell
scripting. Perl is good at handling processes and files, and is especially
good at handling text. Perl's hallmarks are practicality and efficiency.
While it is used to do a lot of different things, Perl's most common
applications are system administration utilities and web programming.

This is a metapackage with all the Perl bits and core modules that can be
found in the upstream tarball from perl.org.

If you need only a specific feature, you can install a specific package
instead. E.g. to handle Perl scripts with /usr/bin/perl interpreter,
install perl-interpreter package. See perl-interpreter description for more
details on the Perl decomposition into packages.

-------------------------------------------------------------------------------
-
Update Information:

This release provides Perl 5.24.4 that fixes a heap buffer overflow in the
pack() function and two overflows in the regular expression engine.
-------------------------------------------------------------------------------
-
ChangeLog:

* Mon Apr 16 2018 Petr Pisar <ppisar@redhat.com> - 4:5.26.2-404
- 5.26.2 bump
- Fix CVE-2018-6913 (heap buffer overflow in pp_pack.c) (bug #1567776)
- Fix CVE-2018-6798 (heap read overflow in regexec.c) (bug #1567777)
- Fix CVE-2018-6797 (heap write overflow in regcomp.c) (bug #1567778)
* Tue Feb 6 2018 Petr Pisar <ppisar@redhat.com> - 4:5.26.1-403
- Add patch to conditionalize a fix for an old and long fixed bug
in libcrypt / glibc (rhbz#1536752)
- Link XS modules to pthread library to fix linking with -z defs
- Correct shell bangs in tests
- Fix parsing braced subscript after parentheses (RT#8045)
- Fix a heap use after free when moving a stack (RT#131954)
- Call ldconfig scriptlets using a macro
* Tue Jan 9 2018 Petr Pisar <ppisar@redhat.com> - 4:5.26.1-402
- Remove invalid macro definitions from macros.perl (bug #1532539)
- Fix an overflow in the lexer when reading a new line (RT#131793)
- Fix Term::ReadLine not to create spurious &STDERR files (RT#132008)
- Fix a crash when a match for inversely repeated group fails (RT#132017)
- Fix an overflow when parsing a character range with no preceding character
(RT#132245)
- Fix walking symbol table for ISA in Carp
- Fix handling file names with null bytes in stat and lstat functions
(RT#131895)
- Fix a crash when untying an object witout a stash
- Fix deparsing of transliterations with unprintable characters (RT#132405)
- Fix error reporting on do() on a directory (RT#125774)
- Fix stack manipulation when a lexical subroutine is defined in a do block in
a member of an iteration list (RT#132442)
- Fix setting $! when statting a closed filehandle (RT#108288)
- Fix tainting of s/// with overloaded replacement (RT#115266)
- Expand system() arguments before a fork (RT#121105)
- Avoid undefined behavior when copying memory in Glob and pp_caller
(RT#131746)
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1547783 - CVE-2018-6797 perl: heap write overflow in regcomp.c
https://bugzilla.redhat.com/show_bug.cgi?id=1547783
[ 2 ] Bug #1547779 - CVE-2018-6798 perl: heap read overflow in regexec.c
https://bugzilla.redhat.com/show_bug.cgi?id=1547779
[ 3 ] Bug #1547772 - CVE-2018-6913 perl: heap buffer overflow in pp_pack.c
https://bugzilla.redhat.com/show_bug.cgi?id=1547772
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2018-1c8b49fbc7' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung