Login
Newsletter
Werbung

Sicherheit: Ausführen von Code mit höheren Privilegien in Linux
Aktuelle Meldungen Distributionen
Name: Ausführen von Code mit höheren Privilegien in Linux
ID: USN-3633-1
Distribution: Ubuntu
Plattformen: Ubuntu 16.04 LTS
Datum: Di, 24. April 2018, 10:35
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16995
Applikationen: Linux

Originalnachricht


--===============5274482068951531107==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="Yylu36WmvOXNoKYn"
Content-Disposition: inline


--Yylu36WmvOXNoKYn
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

==========================================================================
Ubuntu Security Notice USN-3633-1
April 24, 2018

linux-euclid vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS

Summary:

The system could be made to crash or run programs as an administrator.

Software Description:
- linux-euclid: Linux kernel for Intel Euclid systems

Details:

Jann Horn discovered that the Berkeley Packet Filter (BPF) implementation
in the Linux kernel improperly performed sign extension in some situations.
A local attacker could use this to cause a denial of service (system crash)
or possibly execute arbitrary code. (CVE-2017-16995)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
linux-image-4.4.0-9026-euclid 4.4.0-9026.28
linux-image-euclid 4.4.0.9026.27

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
https://usn.ubuntu.com/usn/usn-3633-1
CVE-2017-16995

Package Information:
https://launchpad.net/ubuntu/+source/linux-euclid/4.4.0-9026.28


--Yylu36WmvOXNoKYn
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEpgY7tWAjCaQ8jrvULwmejQBegfQFAlre1BsACgkQLwmejQBe
gfQRvhAAm9F6JWZzjad0UdS2le3Qe/3aBRA9MFXu+YPSQsHQS9tH6n4FrTHE0Ka8
x7pEMpuXOSBsqSeowPzC3OeVf87L0VfeQtRg5rEZJQRXECz0j0PC9G37dHmcDecs
BXasz+xKP/zKVuOeCxscd5hMPG0S4ik3+W9R5HnZXYkpK4w/eX+CrN5giUx8WLy4
Xc1NRSMpkuTmI9Q7J7jfNRqjI5B9NXvCNsIvV5pLCm318a9DJPYySUEePtMWqSKo
T9BYHNBVHP371tNVxH/3UvWJ5YZ9QZJhFLrWSmUugt29LPZOSyyGVE8QatXNe6qM
3SR5vCPRSpBK2jCzyYTWP9JG7UiBMJWLtyb4t6xpT5jQZnxUbEsL9A5qnnwy095t
XUsew4zsEUM2TZUhcCnkjKScB2O1+UrQWn+mbfinDx0Yp8d/Z7I3a7Lh04Oku41z
2A3Ejo552qKdpO9W1rTGFJ9t/Mmfr7LcFuBg19zmJpLCoZRXxY51+VeFjE2jSBp9
8xbnxkYTEySsszlZyXEHERALvRUA3hVVw/o3HMeDGdCmK+EuMxmsamXbW0qi562p
NRAUXZmqVhlmwo1r72SkgxdXkiJxJZV5XADnUzqBq/dtscy8aFhQZhxBzhDijsaA
wja4eCN4YTw7EFGIbWJLeQR4yfxIu8YpyNweaLmzOkDWvxTYJyA=
=hU6F
-----END PGP SIGNATURE-----

--Yylu36WmvOXNoKYn--


--===============5274482068951531107==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung