Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in cups-filters
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in cups-filters
ID: FEDORA-2018-f2e1c09437
Distribution: Fedora
Plattformen: Fedora 27
Datum: Mo, 30. April 2018, 22:03
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11627
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12595
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9918
Applikationen: cups-filters

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2018-f2e1c09437
2018-04-30 16:33:57.130928
-------------------------------------------------------------------------------
-

Name : cups-filters
Product : Fedora 27
Version : 1.16.1
Release : 5.fc27
URL : cups-filters
Summary : OpenPrinting CUPS filters and backends
Description :
Contains backends, filters, and other software that was
once part of the core CUPS distribution but is no longer maintained by
Apple Inc. In addition it contains additional filters developed
independently of Apple, especially filters for the PDF-centric printing
workflow introduced by OpenPrinting.

-------------------------------------------------------------------------------
-
Update Information:

Rebase to qpdf-7.1.1 because of security fixes for CVE-2018-9918,
CVE-2017-11627, CVE-2017-12595.
-------------------------------------------------------------------------------
-
ChangeLog:

* Wed Apr 18 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.16.1-5
- rebuilt with qpdf-7.1.1
* Tue Jan 2 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.16.1-4
- 1529680 - set CreateIPPPrintQueues to ALL and LocalRemoteCUPSQueueNaming to
RemoteName
* Mon Nov 20 2017 Zdenek Dohnal <zdohnal@redhat.com> - 1.16.1-3
- fixing patch for upstream issue 1413
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1566756 - CVE-2018-9918 qpdf: stack exhaustion in QPDFObjectHandle
and QPDF_Dictionary classes in libqpdf.a
https://bugzilla.redhat.com/show_bug.cgi?id=1566756
[ 2 ] Bug #1475517 - CVE-2017-11627 qpdf: Infinite loop in PointerHolder
function in PointerHolder.hh
https://bugzilla.redhat.com/show_bug.cgi?id=1475517
[ 3 ] Bug #1485847 - CVE-2017-12595 qpdf: Stack overflow when processing
deeply nested arrays and dictionaries
https://bugzilla.redhat.com/show_bug.cgi?id=1485847
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2018-f2e1c09437' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung