Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in WebKitGTK+
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in WebKitGTK+
ID: USN-3640-1
Distribution: Ubuntu
Plattformen: Ubuntu 16.04 LTS, Ubuntu 17.10, Ubuntu 18.04 LTS
Datum: Di, 8. Mai 2018, 22:32
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4200
Applikationen: WebKitGTK+

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============6363899087230425066==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="p9GZeKAWajjh0b3Zm6Buorxl03xdPCL1R"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--p9GZeKAWajjh0b3Zm6Buorxl03xdPCL1R
Content-Type: multipart/mixed;
boundary="F6WtOr8QJAtSaXEO5GK6dtVI6UyFJfCu0";
protected-headers="v1"
From: Marc Deslauriers <marc.deslauriers@canonical.com>
Reply-To: Ubuntu Security <security@ubuntu.com>
To: ubuntu-security-announce@lists.ubuntu.com
Message-ID: <51294cd1-e5cb-e746-27db-8906df5cf111@canonical.com>
Subject: [USN-3640-1] WebKitGTK+ vulnerability

--F6WtOr8QJAtSaXEO5GK6dtVI6UyFJfCu0
Content-Type: text/plain; charset=utf-8
Content-Language: en-C
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3640-1
May 08, 2018

webkit2gtk vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 17.10
- Ubuntu 16.04 LTS

Summary:

A security issue was fixed in WebKitGTK+.

Software Description:
- webkit2gtk: Web content engine library for GTK+

Details:

Ivan Fratric discovered that WebKitGTK+ incorrectly handled certain web
content. If a user were tricked into viewing a malicious website, a remote
attacker could possibly exploit this to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
libjavascriptcoregtk-4.0-18 2.20.2-0ubuntu0.18.04.1
libwebkit2gtk-4.0-37 2.20.2-0ubuntu0.18.04.1

Ubuntu 17.10:
libjavascriptcoregtk-4.0-18 2.20.2-0ubuntu0.17.10.1
libwebkit2gtk-4.0-37 2.20.2-0ubuntu0.17.10.1

Ubuntu 16.04 LTS:
libjavascriptcoregtk-4.0-18 2.20.2-0ubuntu0.16.04.1
libwebkit2gtk-4.0-37 2.20.2-0ubuntu0.16.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart any applications
that use WebKitGTK+, such as Epiphany, to make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3640-1
CVE-2018-4200

Package Information:
https://launchpad.net/ubuntu/+source/webkit2gtk/2.20.2-0ubuntu0.18.04.1
https://launchpad.net/ubuntu/+source/webkit2gtk/2.20.2-0ubuntu0.17.10.1
https://launchpad.net/ubuntu/+source/webkit2gtk/2.20.2-0ubuntu0.16.04.1


--F6WtOr8QJAtSaXEO5GK6dtVI6UyFJfCu0--

--p9GZeKAWajjh0b3Zm6Buorxl03xdPCL1R
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJa8b/GAAoJEGVp2FWnRL6T2CwP/004adky2VXiY8XA8zqQlmzL
0+NRSubIC+pYwow2iLcupC5Pd0e5iEQBIvJ9it5QaAqz9CLBArkA4xpIfvO5QqoC
NxI7ql9K5nnCh3cqo5jiGAOOV6gDZh673IocTuklYBrtH16utHLSsBAR81L/IAoE
I038j42F4yqG5Po7eOBLLFRkwxlEUcdq7rdB9eSqj+6sEE5yRpsnUK5CALcUyfwu
C8Qz4sME6RABIfIw57unps2Rgt15IrPt0YsU12Nv1Qpgf7ckWGcgxljKbsFt3DTL
RXwt6Dzhcp/hz/wc81xdQ9kdgIVU81EDbTkGkTzBYSzmcgErHDLZkKYvbkG3R/1+
pWda4A3X2YXwIfopl9gVFJYuypsNtlZ/uUsIKp3ryX8xxbxn8G6VYOHYP9gGs93j
FqVT/+mm6rT3ST8S4DAZGYut/itCmTQomFQSF9EeP6nnLz9r2q5b1FwIP09rUYbb
6VOWj5xIqoKAP5pBtG2btDHB6WTI3JO702CJaHDg7DNXnUy9sPFId0iD6YNgLl1g
c8sphAqGllR2hcDTDjosC4JdNGZxcnQexrZz01aM0+9O+ckGAqBYUZYPJoLpZiZ1
YX5mFjXWUee4CWet+YvKNzBsJNirUfyYbg0+Pwvc2OKq1AQeaIxBKqffXSRBB6Zz
NrFsS4/XN8Na6RjXbXnG
=uyfI
-----END PGP SIGNATURE-----

--p9GZeKAWajjh0b3Zm6Buorxl03xdPCL1R--


--===============6363899087230425066==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============6363899087230425066==--
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung