Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in LilyPond
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in LilyPond
ID: openSUSE-SU-2018:1360-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mo, 21. Mai 2018, 08:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10992
Applikationen: LilyPond

Originalnachricht

   openSUSE Security Update: Security update for lilypond
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1360-1
Rating: moderate
References: #1041090 #1093056
Cross-References: CVE-2018-10992
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for lilypond fixes the following issues:

- CVE-2018-10992: lilypond: Does not validate strings before launching
the program specified by the BROWSER environment variable, which
allows remote attackers to conduct argument-injection attacks
(bsc#1093056)
- packages do not build reproducibly from unsorted input (bsc#1041090)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-487=1



Package List:

- openSUSE Leap 42.3 (x86_64):

lilypond-2.18.2-7.3.1
lilypond-debuginfo-2.18.2-7.3.1
lilypond-debugsource-2.18.2-7.3.1

- openSUSE Leap 42.3 (noarch):

lilypond-century-schoolbook-l-fonts-2.18.2-7.3.1
lilypond-doc-2.18.2-7.3.1
lilypond-doc-cs-2.18.2-7.3.1
lilypond-doc-de-2.18.2-7.3.1
lilypond-doc-es-2.18.2-7.3.1
lilypond-doc-fr-2.18.2-7.3.1
lilypond-doc-hu-2.18.2-7.3.1
lilypond-doc-it-2.18.2-7.3.1
lilypond-doc-ja-2.18.2-7.3.1
lilypond-doc-nl-2.18.2-7.3.1
lilypond-doc-zh-2.18.2-7.3.1
lilypond-emmentaler-fonts-2.18.2-7.3.1
lilypond-fonts-common-2.18.2-7.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10992.html
https://bugzilla.suse.com/1041090
https://bugzilla.suse.com/1093056

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung