Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in PowerDNS Authoritative Server
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in PowerDNS Authoritative Server
ID: openSUSE-SU-2018:1384-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mi, 23. Mai 2018, 17:03
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1046
Applikationen: PowerDNS Authoritative Server

Originalnachricht

   openSUSE Security Update: Security update for pdns
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1384-1
Rating: moderate
References: #1092540
Cross-References: CVE-2018-1046
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for pdns fixes the following issue:

- CVE-2018-1046: An issue has been found in the dnsreplay tool provided
with PowerDNS Authoritative, where replaying a specially crafted PCAP
file can trigger a stack-based buffer
overflow, leading to a crash and potentially arbitrary code execution.
This buffer overflow only occurs when the -ecs-stamp
option of dnsreplay is used. (boo#1092540)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-491=1



Package List:

- openSUSE Leap 42.3 (x86_64):

pdns-4.0.3-12.1
pdns-backend-geoip-4.0.3-12.1
pdns-backend-geoip-debuginfo-4.0.3-12.1
pdns-backend-godbc-4.0.3-12.1
pdns-backend-godbc-debuginfo-4.0.3-12.1
pdns-backend-ldap-4.0.3-12.1
pdns-backend-ldap-debuginfo-4.0.3-12.1
pdns-backend-lua-4.0.3-12.1
pdns-backend-lua-debuginfo-4.0.3-12.1
pdns-backend-mydns-4.0.3-12.1
pdns-backend-mydns-debuginfo-4.0.3-12.1
pdns-backend-mysql-4.0.3-12.1
pdns-backend-mysql-debuginfo-4.0.3-12.1
pdns-backend-postgresql-4.0.3-12.1
pdns-backend-postgresql-debuginfo-4.0.3-12.1
pdns-backend-remote-4.0.3-12.1
pdns-backend-remote-debuginfo-4.0.3-12.1
pdns-backend-sqlite3-4.0.3-12.1
pdns-backend-sqlite3-debuginfo-4.0.3-12.1
pdns-debuginfo-4.0.3-12.1
pdns-debugsource-4.0.3-12.1


References:

https://www.suse.com/security/cve/CVE-2018-1046.html
https://bugzilla.suse.com/1092540

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung