Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in librelp
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in librelp
ID: RHSA-2018:1704-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: Mi, 23. Mai 2018, 19:06
Referenzen: https://access.redhat.com/security/cve/CVE-2018-1000140
Applikationen: librelp

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: librelp security update
Advisory ID: RHSA-2018:1704-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2018:1704
Issue date: 2018-05-23
CVE Names: CVE-2018-1000140
=====================================================================

1. Summary:

An update for librelp is now available for Red Hat Enterprise Linux 7.4
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.4) - x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.4) - x86_64
Red Hat Enterprise Linux Server EUS (v. 7.4) - aarch64, ppc64, ppc64le, s390x,
x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.4) - aarch64, ppc64,
ppc64le, s390x, x86_64

3. Description:

Librelp is an easy-to-use library for the Reliable Event Logging Protocol
(RELP) protocol. RELP is a general-purpose, extensible logging protocol.

Security Fix(es):

* librelp: Stack-based buffer overflow in relpTcpChkPeerName function in
src/tcp.c (CVE-2018-1000140)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, refer to the CVE page(s) listed in
the References section.

Red Hat would like to thank Rainer Gerhards (rsyslog) for reporting this
issue. Upstream acknowledges Bas van Schaik (lgtm.com / Semmle) and Kevin
Backhouse (lgtm.com / Semmle) as the original reporters.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1560084 - CVE-2018-1000140 librelp: Stack-based buffer overflow in
relpTcpChkPeerName function in src/tcp.c

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.4):

Source:
librelp-1.2.12-1.el7_4.1.src.rpm

x86_64:
librelp-1.2.12-1.el7_4.1.i686.rpm
librelp-1.2.12-1.el7_4.1.x86_64.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.i686.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.4):

x86_64:
librelp-debuginfo-1.2.12-1.el7_4.1.i686.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.x86_64.rpm
librelp-devel-1.2.12-1.el7_4.1.i686.rpm
librelp-devel-1.2.12-1.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.4):

Source:
librelp-1.2.12-1.el7_4.1.src.rpm

aarch64:
librelp-1.2.12-1.el7_4.1.aarch64.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.aarch64.rpm

ppc64:
librelp-1.2.12-1.el7_4.1.ppc.rpm
librelp-1.2.12-1.el7_4.1.ppc64.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.ppc.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.ppc64.rpm

ppc64le:
librelp-1.2.12-1.el7_4.1.ppc64le.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.ppc64le.rpm

s390x:
librelp-1.2.12-1.el7_4.1.s390.rpm
librelp-1.2.12-1.el7_4.1.s390x.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.s390.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.s390x.rpm

x86_64:
librelp-1.2.12-1.el7_4.1.i686.rpm
librelp-1.2.12-1.el7_4.1.x86_64.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.i686.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.4):

aarch64:
librelp-debuginfo-1.2.12-1.el7_4.1.aarch64.rpm
librelp-devel-1.2.12-1.el7_4.1.aarch64.rpm

ppc64:
librelp-debuginfo-1.2.12-1.el7_4.1.ppc.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.ppc64.rpm
librelp-devel-1.2.12-1.el7_4.1.ppc.rpm
librelp-devel-1.2.12-1.el7_4.1.ppc64.rpm

ppc64le:
librelp-debuginfo-1.2.12-1.el7_4.1.ppc64le.rpm
librelp-devel-1.2.12-1.el7_4.1.ppc64le.rpm

s390x:
librelp-debuginfo-1.2.12-1.el7_4.1.s390.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.s390x.rpm
librelp-devel-1.2.12-1.el7_4.1.s390.rpm
librelp-devel-1.2.12-1.el7_4.1.s390x.rpm

x86_64:
librelp-debuginfo-1.2.12-1.el7_4.1.i686.rpm
librelp-debuginfo-1.2.12-1.el7_4.1.x86_64.rpm
librelp-devel-1.2.12-1.el7_4.1.i686.rpm
librelp-devel-1.2.12-1.el7_4.1.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-1000140
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBWwWOodzjgjWX9erEAQjPVxAAnBRa3zK0DcJ/Oe2Q9kH//5Jfw5lAsfIO
hyBkJchvZrMBCMwiQt9wtDF4Vrp5EarQkEyOsIsU4qberXZdnfr3BiN6yvDSHui8
4+mTAKeyudKCed5hmyLk3LZ8C//utUnYeQcwR5bGH9vcXj+srGNw2UufyfyHeRjS
4IxC2HcAoAGFoK2BnZEnBrk1gyjgFsdPiR6+kydOWWsxhfLpQzCVKAOldploHFym
RkrGuRqHWawDmM40D0k3S8eIzqPloK7O4iYLs9D5EACM7dMO/tEpPJUxCqLroCPW
6eTyJ/MJC2HSTPNmfq0IiZpjP67MhYyKYaYPF2GC6khmYRRuIWPlFKM9BVBkPJI6
iTjk76xPKZ9oBTkP02v4fXpLebElIlL4GWwrcEm2btqHCIfzidi341NNCMbclxQg
kP4onNb5cQVaqGFy3Fj+M8SLBkML1uWjvMd0jrKHtglPt9lxuPiZf/hD1SOPEkFs
yyGoWqu6GtcBrtzOvztn1xGScoLdf4WAaOnblGLdke0uh2sA8Tv0Bho3TdFIwbm5
L2cd0P8D3A8gkz77N1A8F0jMB5c58SR2r0kWwp5aa3JIOmZUcvvMqjAOjksVqmmf
dNpMaJPPXvdMRsngVp/UCDOWhZ3RmqQYJUIULR2Iq+CmuoOwq+nVGYbkJelAUICp
KuHfsuojUlQ=
=RH9q
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung