Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in GNU Bash
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in GNU Bash
ID: openSUSE-SU-2018:1419-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Fr, 25. Mai 2018, 11:58
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0634
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-7543
Applikationen: GNU Bash

Originalnachricht

   openSUSE Security Update: Security update for bash
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1419-1
Rating: moderate
References: #1000396 #1001299 #1086247
Cross-References: CVE-2016-0634 CVE-2016-7543
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for bash fixes the following issues:

Security issues fixed:

- CVE-2016-7543: A code execution possibility via SHELLOPTS+PS4 variable
was fixed (bsc#1001299)
- CVE-2016-0634: Arbitrary code execution via malicious hostname was fixed
(bsc#1000396)

Non-security issues fixed:

- Fix repeating self-calling of traps due the combination of a
non-interactive shell, a trap handler for SIGINT, an external process in
the trap handler, and a SIGINT within the trap after the external
process runs. (bsc#1086247)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-516=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

bash-4.3-83.6.1
bash-debuginfo-4.3-83.6.1
bash-debugsource-4.3-83.6.1
bash-devel-4.3-83.6.1
bash-loadables-4.3-83.6.1
bash-loadables-debuginfo-4.3-83.6.1
libreadline6-6.3-83.6.1
libreadline6-debuginfo-6.3-83.6.1
readline-devel-6.3-83.6.1

- openSUSE Leap 42.3 (x86_64):

bash-debuginfo-32bit-4.3-83.6.1
libreadline6-32bit-6.3-83.6.1
libreadline6-debuginfo-32bit-6.3-83.6.1
readline-devel-32bit-6.3-83.6.1

- openSUSE Leap 42.3 (noarch):

bash-doc-4.3-83.6.1
bash-lang-4.3-83.6.1
readline-doc-6.3-83.6.1


References:

https://www.suse.com/security/cve/CVE-2016-0634.html
https://www.suse.com/security/cve/CVE-2016-7543.html
https://bugzilla.suse.com/1000396
https://bugzilla.suse.com/1001299
https://bugzilla.suse.com/1086247

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung