Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in Weex
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in Weex
ID: 200510-09
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 8. Oktober 2005, 18:28
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3150
Applikationen: weex

Originalnachricht

--nextPart1187484.F2UYQfuiKc
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200510-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Weex: Format string vulnerability
Date: October 08, 2005
Bugs: #107849
ID: 200510-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Weex contains a format string error that may be exploited by malicious
servers to execute arbitrary code.

Background
==========

Weex is a non-interactive FTP client typically used to update web
pages.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-ftp/weex < 2.6.1.5-r1 >= 2.6.1.5-r1

Description
===========

Ulf Harnhammar discovered a format string bug in Weex that can be
triggered when it is first run (or when its cache files are rebuilt,
using the -r option).

Impact
======

An attacker could setup a malicious FTP server which, when accessed
using Weex, could trigger the format string bug and end up executing
arbitrary code with the rights of the user running Weex.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Weex users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-ftp/weex-2.6.1.5-r1"

References
==========

[ 1 ] CAN-2005-3150
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-3150

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200510-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart1187484.F2UYQfuiKc
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQBDR/J5zKC5hMHO6rkRAmv+AJ0d9HZEcZFjEQ/Z2KjaJykx6N4rOgCcDhg7
iiHhf1EcqxAFUKhTr/Vl/+4=
=cRut
-----END PGP SIGNATURE-----

--nextPart1187484.F2UYQfuiKc--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung