Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in poppler
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in poppler
ID: openSUSE-SU-2018:1721-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Sa, 16. Juni 2018, 20:01
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14928
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000456
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14976
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14975
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14518
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14977
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14617
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14520
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9865
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14517
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15565
Applikationen: poppler

Originalnachricht

   openSUSE Security Update: Security update for poppler
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1721-1
Rating: moderate
References: #1045939 #1059066 #1059101 #1059155 #1060220
#1061092 #1061263 #1061264 #1061265 #1064593
#1074453
Cross-References: CVE-2017-1000456 CVE-2017-14517 CVE-2017-14518
CVE-2017-14520 CVE-2017-14617 CVE-2017-14928
CVE-2017-14975 CVE-2017-14976 CVE-2017-14977
CVE-2017-15565 CVE-2017-9865
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:

This update for poppler fixes the following issues:

These security issues were fixed:

- CVE-2017-14517: Prevent NULL Pointer dereference in the
XRef::parseEntry() function via a crafted PDF document (bsc#1059066).
- CVE-2017-9865: Fixed a stack-based buffer overflow vulnerability in
GfxState.cc that would have allowed attackers to facilitate a
denial-of-service attack via specially crafted PDF documents.
(bsc#1045939)
- CVE-2017-14518: Remedy a floating point exception in
isImageInterpolationRequired() that could have been exploited using a
specially crafted PDF document. (bsc#1059101)
- CVE-2017-14520: Remedy a floating point exception in
Splash::scaleImageYuXd() that could have been exploited using a
specially crafted PDF document. (bsc#1059155)
- CVE-2017-14617: Fixed a floating point exception in Stream.cc, which may
lead to a potential attack when handling malicious PDF files.
(bsc#1060220)
- CVE-2017-14928: Fixed a NULL Pointer dereference in
AnnotRichMedia::Configuration::Configuration() in Annot.cc, which may
lead to a potential attack when handling malicious PDF files.
(bsc#1061092)
- CVE-2017-14975: Fixed a NULL pointer dereference vulnerability, that
existed because a data structure in FoFiType1C.cc was not initialized,
which allowed an attacker to launch a denial of service attack.
(bsc#1061263)
- CVE-2017-14976: Fixed a heap-based buffer over-read vulnerability in
FoFiType1C.cc that occurred when an out-of-bounds font dictionary index
was encountered, which allowed an attacker to launch a denial of service
attack. (bsc#1061264)
- CVE-2017-14977: Fixed a NULL pointer dereference vulnerability in the
FoFiTrueType::getCFFBlock() function in FoFiTrueType.cc that occurred
due to lack of validation of a table pointer, which allows an attacker
to launch a denial of service attack. (bsc#1061265)
- CVE-2017-15565: Prevent NULL Pointer dereference in the
GfxImageColorMap::getGrayLine() function via a crafted PDF document
(bsc#1064593).
- CVE-2017-1000456: Validate boundaries in TextPool::addWord to prevent
overflows in subsequent calculations (bsc#1074453).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-648=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libpoppler-cpp0-0.43.0-8.1
libpoppler-cpp0-debuginfo-0.43.0-8.1
libpoppler-devel-0.43.0-8.1
libpoppler-glib-devel-0.43.0-8.1
libpoppler-glib8-0.43.0-8.1
libpoppler-glib8-debuginfo-0.43.0-8.1
libpoppler-qt4-4-0.43.0-8.1
libpoppler-qt4-4-debuginfo-0.43.0-8.1
libpoppler-qt4-devel-0.43.0-8.1
libpoppler-qt5-1-0.43.0-8.1
libpoppler-qt5-1-debuginfo-0.43.0-8.1
libpoppler-qt5-devel-0.43.0-8.1
libpoppler60-0.43.0-8.1
libpoppler60-debuginfo-0.43.0-8.1
poppler-debugsource-0.43.0-8.1
poppler-qt-debugsource-0.43.0-8.1
poppler-qt5-debugsource-0.43.0-8.1
poppler-tools-0.43.0-8.1
poppler-tools-debuginfo-0.43.0-8.1
typelib-1_0-Poppler-0_18-0.43.0-8.1

- openSUSE Leap 42.3 (x86_64):

libpoppler-cpp0-32bit-0.43.0-8.1
libpoppler-cpp0-debuginfo-32bit-0.43.0-8.1
libpoppler-glib8-32bit-0.43.0-8.1
libpoppler-glib8-debuginfo-32bit-0.43.0-8.1
libpoppler-qt4-4-32bit-0.43.0-8.1
libpoppler-qt4-4-debuginfo-32bit-0.43.0-8.1
libpoppler-qt5-1-32bit-0.43.0-8.1
libpoppler-qt5-1-debuginfo-32bit-0.43.0-8.1
libpoppler60-32bit-0.43.0-8.1
libpoppler60-debuginfo-32bit-0.43.0-8.1


References:

https://www.suse.com/security/cve/CVE-2017-1000456.html
https://www.suse.com/security/cve/CVE-2017-14517.html
https://www.suse.com/security/cve/CVE-2017-14518.html
https://www.suse.com/security/cve/CVE-2017-14520.html
https://www.suse.com/security/cve/CVE-2017-14617.html
https://www.suse.com/security/cve/CVE-2017-14928.html
https://www.suse.com/security/cve/CVE-2017-14975.html
https://www.suse.com/security/cve/CVE-2017-14976.html
https://www.suse.com/security/cve/CVE-2017-14977.html
https://www.suse.com/security/cve/CVE-2017-15565.html
https://www.suse.com/security/cve/CVE-2017-9865.html
https://bugzilla.suse.com/1045939
https://bugzilla.suse.com/1059066
https://bugzilla.suse.com/1059101
https://bugzilla.suse.com/1059155
https://bugzilla.suse.com/1060220
https://bugzilla.suse.com/1061092
https://bugzilla.suse.com/1061263
https://bugzilla.suse.com/1061264
https://bugzilla.suse.com/1061265
https://bugzilla.suse.com/1064593
https://bugzilla.suse.com/1074453

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung