Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in ImageMagick
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in ImageMagick
ID: openSUSE-SU-2018:1860-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Sa, 30. Juni 2018, 16:48
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10804
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-13758
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10928
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11251
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18271
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9133
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10805
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11655
Applikationen: ImageMagick

Originalnachricht

   openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1860-1
Rating: moderate
References: #1047356 #1056277 #1087820 #1094204 #1094237
#1095730 #1095812 #1095813
Cross-References: CVE-2017-10928 CVE-2017-13758 CVE-2017-18271
CVE-2018-10804 CVE-2018-10805 CVE-2018-11251
CVE-2018-11655 CVE-2018-9133
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available.

Description:

This update for ImageMagick fixes the following issues:

These security issues were fixed:

- CVE-2017-13758: Prevent heap-based buffer overflow in the TracePoint()
function (bsc#1056277).
- CVE-2017-10928: Prevent heap-based buffer over-read in the GetNextToken
function that allowed remote attackers to obtain sensitive information
from process memory or possibly have unspecified other impact via a
crafted SVG document (bsc#1047356).
- CVE-2018-9133: Long compute times in the tiff decoder have been fixed
(bsc#1087820).
- CVE-2018-11251: Heap-based buffer over-read in ReadSUNImage in
coders/sun.c, which allows attackers to cause denial of service
(bsc#1094237).
- CVE-2017-18271: Infinite loop in the function ReadMIFFImage in
coders/miff.c, which allows attackers to cause a denial of service
(bsc#1094204).
- CVE-2018-11655: Memory leak in the GetImagePixelCache in
MagickCore/cache.c was fixed (bsc#1095730)
- CVE-2018-10804: Memory leak in WriteTIFFImage in coders/tiff.c was fixed
(bsc#1095813)
- CVE-2018-10805: Fixed memory leaks in bgr.c, rgb.c, cmyk.c, gray.c,
ycbcr.c (bsc#1095812)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-690=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

ImageMagick-6.8.8.1-64.1
ImageMagick-debuginfo-6.8.8.1-64.1
ImageMagick-debugsource-6.8.8.1-64.1
ImageMagick-devel-6.8.8.1-64.1
ImageMagick-extra-6.8.8.1-64.1
ImageMagick-extra-debuginfo-6.8.8.1-64.1
libMagick++-6_Q16-3-6.8.8.1-64.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-64.1
libMagick++-devel-6.8.8.1-64.1
libMagickCore-6_Q16-1-6.8.8.1-64.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-64.1
libMagickWand-6_Q16-1-6.8.8.1-64.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-64.1
perl-PerlMagick-6.8.8.1-64.1
perl-PerlMagick-debuginfo-6.8.8.1-64.1

- openSUSE Leap 42.3 (noarch):

ImageMagick-doc-6.8.8.1-64.1

- openSUSE Leap 42.3 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-64.1
libMagick++-6_Q16-3-32bit-6.8.8.1-64.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-64.1
libMagick++-devel-32bit-6.8.8.1-64.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-64.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-64.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-64.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-64.1


References:

https://www.suse.com/security/cve/CVE-2017-10928.html
https://www.suse.com/security/cve/CVE-2017-13758.html
https://www.suse.com/security/cve/CVE-2017-18271.html
https://www.suse.com/security/cve/CVE-2018-10804.html
https://www.suse.com/security/cve/CVE-2018-10805.html
https://www.suse.com/security/cve/CVE-2018-11251.html
https://www.suse.com/security/cve/CVE-2018-11655.html
https://www.suse.com/security/cve/CVE-2018-9133.html
https://bugzilla.suse.com/1047356
https://bugzilla.suse.com/1056277
https://bugzilla.suse.com/1087820
https://bugzilla.suse.com/1094204
https://bugzilla.suse.com/1094237
https://bugzilla.suse.com/1095730
https://bugzilla.suse.com/1095812
https://bugzilla.suse.com/1095813

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung