Login
Newsletter
Werbung

Sicherheit: Denial of Service in GraphicsMagick
Aktuelle Meldungen Distributionen
Name: Denial of Service in GraphicsMagick
ID: openSUSE-SU-2018:1862-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3, SUSE openSUSE Leap 15.0
Datum: Sa, 30. Juni 2018, 16:49
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10805
Applikationen: GraphicsMagick

Originalnachricht

   openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1862-1
Rating: low
References: #1075821 #1095812
Cross-References: CVE-2018-10805
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for GraphicsMagick fixes the following issues:

The following security fixes were fixed:

- CVE-2018-10805: Fixed a memory leak in ReadYCBCRImage in coders/ycbcr.c
and rgb.c, cmyk.c and gray.c (boo#1095812)
- Fixed invalid memory reads in dcm.c (boo#1075821#c14)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-689=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-689=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-93.1
GraphicsMagick-debuginfo-1.3.25-93.1
GraphicsMagick-debugsource-1.3.25-93.1
GraphicsMagick-devel-1.3.25-93.1
libGraphicsMagick++-Q16-12-1.3.25-93.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-93.1
libGraphicsMagick++-devel-1.3.25-93.1
libGraphicsMagick-Q16-3-1.3.25-93.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-93.1
libGraphicsMagick3-config-1.3.25-93.1
libGraphicsMagickWand-Q16-2-1.3.25-93.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-93.1
perl-GraphicsMagick-1.3.25-93.1
perl-GraphicsMagick-debuginfo-1.3.25-93.1

- openSUSE Leap 15.0 (x86_64):

GraphicsMagick-1.3.29-lp150.3.6.1
GraphicsMagick-debuginfo-1.3.29-lp150.3.6.1
GraphicsMagick-debugsource-1.3.29-lp150.3.6.1
GraphicsMagick-devel-1.3.29-lp150.3.6.1
libGraphicsMagick++-Q16-12-1.3.29-lp150.3.6.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.29-lp150.3.6.1
libGraphicsMagick++-devel-1.3.29-lp150.3.6.1
libGraphicsMagick-Q16-3-1.3.29-lp150.3.6.1
libGraphicsMagick-Q16-3-debuginfo-1.3.29-lp150.3.6.1
libGraphicsMagick3-config-1.3.29-lp150.3.6.1
libGraphicsMagickWand-Q16-2-1.3.29-lp150.3.6.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.29-lp150.3.6.1
perl-GraphicsMagick-1.3.29-lp150.3.6.1
perl-GraphicsMagick-debuginfo-1.3.29-lp150.3.6.1


References:

https://www.suse.com/security/cve/CVE-2018-10805.html
https://bugzilla.suse.com/1075821
https://bugzilla.suse.com/1095812

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung