Login
Newsletter
Werbung

Sicherheit: Denial of Service in cairo
Aktuelle Meldungen Distributionen
Name: Denial of Service in cairo
ID: openSUSE-SU-2018:1895-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Fr, 6. Juli 2018, 07:13
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9814
Applikationen: Cairo

Originalnachricht

   openSUSE Security Update: Security update for cairo
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1895-1
Rating: moderate
References: #1049092
Cross-References: CVE-2017-9814
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cairo fixes the following issues:

The following security vulnerability was addressed:

- CVE-2017-9814: Fixed and out-of-bounds read in cairo-truetype-subset.c
by replacing the malloc implementation with _cairo_malloc and checking
the size before memory allocation (bsc#1049092)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-698=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

cairo-debugsource-1.15.10-lp150.3.3.1
cairo-devel-1.15.10-lp150.3.3.1
cairo-tools-1.15.10-lp150.3.3.1
cairo-tools-debuginfo-1.15.10-lp150.3.3.1
libcairo-gobject2-1.15.10-lp150.3.3.1
libcairo-gobject2-debuginfo-1.15.10-lp150.3.3.1
libcairo-script-interpreter2-1.15.10-lp150.3.3.1
libcairo-script-interpreter2-debuginfo-1.15.10-lp150.3.3.1
libcairo2-1.15.10-lp150.3.3.1
libcairo2-debuginfo-1.15.10-lp150.3.3.1

- openSUSE Leap 15.0 (x86_64):

cairo-devel-32bit-1.15.10-lp150.3.3.1
libcairo-gobject2-32bit-1.15.10-lp150.3.3.1
libcairo-gobject2-32bit-debuginfo-1.15.10-lp150.3.3.1
libcairo-script-interpreter2-32bit-1.15.10-lp150.3.3.1
libcairo-script-interpreter2-32bit-debuginfo-1.15.10-lp150.3.3.1
libcairo2-32bit-1.15.10-lp150.3.3.1
libcairo2-32bit-debuginfo-1.15.10-lp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2017-9814.html
https://bugzilla.suse.com/1049092

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung