Login
Newsletter
Werbung

Sicherheit: Überschreiben von Dateien in perl
Aktuelle Meldungen Distributionen
Name: Überschreiben von Dateien in perl
ID: openSUSE-SU-2018:2010-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Fr, 20. Juli 2018, 07:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12015
Applikationen: Perl

Originalnachricht

   openSUSE Security Update: Security update for perl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2010-1
Rating: important
References: #1068565 #1096718
Cross-References: CVE-2018-12015
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for perl fixes the following issues:

This security issue was fixed:

- CVE-2018-12015: The Archive::Tar module allowed remote attackers to
bypass a directory-traversal protection mechanism and overwrite
arbitrary files (bsc#1096718)

This non-security issue was fixed:

- fix debugger crash in tab completion with Term::ReadLine::Gnu
[bsc#1068565]

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-750=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

perl-5.18.2-15.2
perl-base-5.18.2-15.2
perl-base-debuginfo-5.18.2-15.2
perl-debuginfo-5.18.2-15.2
perl-debugsource-5.18.2-15.2

- openSUSE Leap 42.3 (x86_64):

perl-32bit-5.18.2-15.2
perl-base-32bit-5.18.2-15.2
perl-base-debuginfo-32bit-5.18.2-15.2
perl-debuginfo-32bit-5.18.2-15.2

- openSUSE Leap 42.3 (noarch):

perl-doc-5.18.2-15.2


References:

https://www.suse.com/security/cve/CVE-2018-12015.html
https://bugzilla.suse.com/1068565
https://bugzilla.suse.com/1096718

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung