Login
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in gdk-pixbuf
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in gdk-pixbuf
ID: openSUSE-SU-2018:2013-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Fr, 20. Juli 2018, 07:20
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000422
Applikationen: Gtk+

Originalnachricht

   openSUSE Security Update: Security update for gdk-pixbuf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2013-1
Rating: moderate
References: #1074462
Cross-References: CVE-2017-1000422
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gdk-pixbuf fixes the following security issue:

- CVE-2017-1000422: Prevent several integer overflow in the gif_get_lzw
function resulting in memory corruption and potential code execution
(bsc#1074462).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-741=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

gdk-pixbuf-debugsource-2.34.0-16.1
gdk-pixbuf-devel-2.34.0-16.1
gdk-pixbuf-devel-debuginfo-2.34.0-16.1
gdk-pixbuf-query-loaders-2.34.0-16.1
gdk-pixbuf-query-loaders-debuginfo-2.34.0-16.1
libgdk_pixbuf-2_0-0-2.34.0-16.1
libgdk_pixbuf-2_0-0-debuginfo-2.34.0-16.1
typelib-1_0-GdkPixbuf-2_0-2.34.0-16.1

- openSUSE Leap 42.3 (noarch):

gdk-pixbuf-lang-2.34.0-16.1

- openSUSE Leap 42.3 (x86_64):

gdk-pixbuf-devel-32bit-2.34.0-16.1
gdk-pixbuf-devel-debuginfo-32bit-2.34.0-16.1
gdk-pixbuf-query-loaders-32bit-2.34.0-16.1
gdk-pixbuf-query-loaders-debuginfo-32bit-2.34.0-16.1
libgdk_pixbuf-2_0-0-32bit-2.34.0-16.1
libgdk_pixbuf-2_0-0-debuginfo-32bit-2.34.0-16.1


References:

https://www.suse.com/security/cve/CVE-2017-1000422.html
https://bugzilla.suse.com/1074462

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung