Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in e2fsprogs
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in e2fsprogs
ID: openSUSE-SU-2018:2133-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 28. Juli 2018, 20:38
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1572
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0247
Applikationen: e2fsprogs

Originalnachricht

   openSUSE Security Update: Security update for e2fsprogs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2133-1
Rating: moderate
References: #1009532 #1038194 #915402 #918346 #960273

Cross-References: CVE-2015-0247 CVE-2015-1572
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has three
fixes is now available.

Description:

This update for e2fsprogs fixes the following issues:

Security issues fixed:

- CVE-2015-0247: Fixed couple of heap overflows in e2fsprogs (fsck,
dumpe2fs, e2image...) (bsc#915402).
- CVE-2015-1572: Fixed potential buffer overflow in closefs() (bsc#918346).

Bug fixes:

- bsc#1038194: generic/405 test fails with /dev/mapper/thin-vol is
inconsistent on ext4 file system.
- bsc#1009532: resize2fs hangs when trying to resize a large ext4 file
system.
- bsc#960273: xfsprogs does not call %{?regenerate_initrd_post}.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-771=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

e2fsprogs-1.43.8-lp150.3.3.1
e2fsprogs-debuginfo-1.43.8-lp150.3.3.1
e2fsprogs-debugsource-1.43.8-lp150.3.3.1
e2fsprogs-devel-1.43.8-lp150.3.3.1
libcom_err-devel-1.43.8-lp150.3.3.1
libcom_err-devel-static-1.43.8-lp150.3.3.1
libcom_err2-1.43.8-lp150.3.3.1
libcom_err2-debuginfo-1.43.8-lp150.3.3.1
libext2fs-devel-1.43.8-lp150.3.3.1
libext2fs-devel-static-1.43.8-lp150.3.3.1
libext2fs2-1.43.8-lp150.3.3.1
libext2fs2-debuginfo-1.43.8-lp150.3.3.1

- openSUSE Leap 15.0 (x86_64):

e2fsprogs-32bit-debuginfo-1.43.8-lp150.3.3.1
libcom_err-devel-32bit-1.43.8-lp150.3.3.1
libcom_err2-32bit-1.43.8-lp150.3.3.1
libcom_err2-32bit-debuginfo-1.43.8-lp150.3.3.1
libext2fs-devel-32bit-1.43.8-lp150.3.3.1
libext2fs2-32bit-1.43.8-lp150.3.3.1
libext2fs2-32bit-debuginfo-1.43.8-lp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2015-0247.html
https://www.suse.com/security/cve/CVE-2015-1572.html
https://bugzilla.suse.com/1009532
https://bugzilla.suse.com/1038194
https://bugzilla.suse.com/915402
https://bugzilla.suse.com/918346
https://bugzilla.suse.com/960273

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung