Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in libcdio
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in libcdio
ID: SUSE-SU-2018:2236-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Desktop Applications 15
Datum: Di, 7. August 2018, 18:38
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18199
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18201
Applikationen: GNU Compact Disc Input and Control Library

Originalnachricht

   SUSE Security Update: Security update for libcdio
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:2236-1
Rating: low
References: #1082821 #1082877
Cross-References: CVE-2017-18199 CVE-2017-18201
Affected Products:
SUSE Linux Enterprise Module for Desktop Applications 15
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libcdio fixes the following issues:

The following security vulnerabilities were addressed:

- CVE-2017-18199: Fixed a NULL pointer dereference in realloc_symlink in
rock.c (bsc#1082821)
- CVE-2017-18201: Fixed a double free vulnerability in
get_cdtext_generic() in _cdio_generic.c (bsc#1082877)
- Fixed several memory leaks (bsc#1082821)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Desktop Applications 15:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2018-1512=1



Package List:

- SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le
s390x x86_64):

libcdio++0-0.94-6.3.1
libcdio++0-debuginfo-0.94-6.3.1
libcdio-debugsource-0.94-6.3.1
libcdio-devel-0.94-6.3.1
libcdio16-0.94-6.3.1
libcdio16-debuginfo-0.94-6.3.1
libiso9660-10-0.94-6.3.1
libiso9660-10-debuginfo-0.94-6.3.1
libudf0-0.94-6.3.1
libudf0-debuginfo-0.94-6.3.1


References:

https://www.suse.com/security/cve/CVE-2017-18199.html
https://www.suse.com/security/cve/CVE-2017-18201.html
https://bugzilla.suse.com/1082821
https://bugzilla.suse.com/1082877

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung