Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in samba
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in samba
ID: SUSE-SU-2018:2318-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise High Availability 15
Datum: Di, 14. August 2018, 16:43
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1139
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1140
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10918
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10919
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10858
Applikationen: Samba

Originalnachricht

   SUSE Security Update: Security update for samba
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:2318-1
Rating: important
References: #1095048 #1095056 #1095057 #1103411 #1103414

Cross-References: CVE-2018-10858 CVE-2018-10918 CVE-2018-10919
CVE-2018-1139 CVE-2018-1140
Affected Products:
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise High Availability 15
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for samba fixes the following issues:

The following security vulnerabilities were fixed:

- CVE-2018-1139: Disable NTLMv1 auth if smb.conf doesn't allow it;
(bsc#1095048)
- CVE-2018-1140: ldbsearch '(distinguishedName=abc)' and DNS query
with
escapes crashes; (bsc#1095056)
- CVE-2018-10919: Confidential attribute disclosure via substring search;
(bsc#1095057)
- CVE-2018-10858: smbc_urlencode helper function is a subject to buffer
overflow; (bsc#1103411)
- CVE-2018-10918: Fix NULL ptr dereference in DsCrackNames on a user
without a SPN; (bsc#1103414)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-1555=1

- SUSE Linux Enterprise High Availability 15:

zypper in -t patch SUSE-SLE-Product-HA-15-2018-1555=1



Package List:

- SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
x86_64):

libdcerpc-binding0-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc-binding0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc-samr-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc-samr0-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc-samr0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc0-4.7.8+git.86.94b6d10f7dd-4.15.1
libdcerpc0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-krb5pac-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-krb5pac0-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-krb5pac0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-nbt-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-nbt0-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-nbt0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-standard-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-standard0-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr-standard0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr0-4.7.8+git.86.94b6d10f7dd-4.15.1
libndr0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libnetapi-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libnetapi0-4.7.8+git.86.94b6d10f7dd-4.15.1
libnetapi0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-credentials-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-credentials0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-credentials0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-errors-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-errors0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-errors0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-hostconfig-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-hostconfig0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-hostconfig0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-passdb-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-passdb0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-passdb0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-policy-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-policy0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-util-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-util0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamba-util0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamdb-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamdb0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsamdb0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbclient-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbclient0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbclient0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbconf-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbconf0-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbconf0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbldap-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbldap2-4.7.8+git.86.94b6d10f7dd-4.15.1
libsmbldap2-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libtevent-util-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libtevent-util0-4.7.8+git.86.94b6d10f7dd-4.15.1
libtevent-util0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
libwbclient-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
libwbclient0-4.7.8+git.86.94b6d10f7dd-4.15.1
libwbclient0-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-client-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-client-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-core-devel-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-debugsource-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-libs-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-libs-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-winbind-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-winbind-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1

- SUSE Linux Enterprise High Availability 15 (aarch64 ppc64le s390x x86_64):

ctdb-4.7.8+git.86.94b6d10f7dd-4.15.1
ctdb-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-debuginfo-4.7.8+git.86.94b6d10f7dd-4.15.1
samba-debugsource-4.7.8+git.86.94b6d10f7dd-4.15.1


References:

https://www.suse.com/security/cve/CVE-2018-10858.html
https://www.suse.com/security/cve/CVE-2018-10918.html
https://www.suse.com/security/cve/CVE-2018-10919.html
https://www.suse.com/security/cve/CVE-2018-1139.html
https://www.suse.com/security/cve/CVE-2018-1140.html
https://bugzilla.suse.com/1095048
https://bugzilla.suse.com/1095056
https://bugzilla.suse.com/1095057
https://bugzilla.suse.com/1103411
https://bugzilla.suse.com/1103414

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung