Login
Newsletter
Werbung

Sicherheit: Denial of Service in libheimdal
Aktuelle Meldungen Distributionen
Name: Denial of Service in libheimdal
ID: openSUSE-SU-2018:2376-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Do, 16. August 2018, 17:14
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17439
Applikationen: Heimdal

Originalnachricht

   openSUSE Security Update: Security update for libheimdal
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2376-1
Rating: important
References: #1047218 #1071675 #1084909
Cross-References: CVE-2017-17439
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for libheimdal to version 7.5.0 fixes the following issues:

The following security vulnerability was fixed:

- CVE-2017-17439: Fixed a remote denial of service vulnerability through
which remote unauthenticated attackers were able to crash the KDC by
sending a crafted UDP packet containing empty data fields for client
name or realm (boo#1071675)

The following other bugs were fixed:

- Override the build date (boo#1047218)
- Use constant hostname (boo#1084909)
- Handle long input lines when reloading database dumps
- In pre-forked mode, correctly clear the process ids of exited children,
allowing new child processes to replace the old.
- Fixed incorrect KDC response when no-cross realm TGT exists, allowing
client requests to fail quickly rather than time out after trying to get
a correct answer from each KDC.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-876=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libheimdal-7.5.0-9.1
libheimdal-debuginfo-7.5.0-9.1
libheimdal-debugsource-7.5.0-9.1
libheimdal-devel-7.5.0-9.1


References:

https://www.suse.com/security/cve/CVE-2017-17439.html
https://bugzilla.suse.com/1047218
https://bugzilla.suse.com/1071675
https://bugzilla.suse.com/1084909

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung