Login
Newsletter
Werbung

Sicherheit: Überschreiben von Dateien in perl-Archive-Zip
Aktuelle Meldungen Distributionen
Name: Überschreiben von Dateien in perl-Archive-Zip
ID: SUSE-SU-2018:2386-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15
Datum: Fr, 17. August 2018, 00:03
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10860
Applikationen: perl-Archive-Zip

Originalnachricht

   SUSE Security Update: Security update for perl-Archive-Zip
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:2386-1
Rating: moderate
References: #1099497
Cross-References: CVE-2018-10860
Affected Products:
SUSE Linux Enterprise Module for Basesystem 15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for perl-Archive-Zip fixes the following security issue:

- CVE-2018-10860: Prevent directory traversal caused by not properly
sanitizing paths while extracting zip files. An attacker able to provide
a specially crafted archive for processing could have used this flaw to
write or overwrite arbitrary files in the context of the perl
interpreter (bsc#1099497)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-1642=1



Package List:

- SUSE Linux Enterprise Module for Basesystem 15 (noarch):

perl-Archive-Zip-1.60-3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10860.html
https://bugzilla.suse.com/1099497

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung