Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in gdm
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in gdm
ID: SUSE-SU-2018:2527-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP3, SUSE Linux Enterprise Server 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP3
Datum: Mo, 27. August 2018, 22:47
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14424
Applikationen: Gnome Display Manager

Originalnachricht

   SUSE Security Update: Security update for gdm
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:2527-1
Rating: moderate
References: #1103737
Cross-References: CVE-2018-14424
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Desktop 12-SP3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gdm fixes the following security issue:

- CVE-2018-14424: The daemon in GDM did not properly unexport display
objects from its D-Bus interface when they are destroyed, which allowed
a local attacker to trigger a use-after-free via a specially crafted
sequence of D-Bus method calls, resulting in a denial of service or
potential code execution (bsc#1103737).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-1765=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-1765=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-1765=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

gdm-debuginfo-3.10.0.1-54.6.3
gdm-debugsource-3.10.0.1-54.6.3
gdm-devel-3.10.0.1-54.6.3

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

gdm-3.10.0.1-54.6.3
gdm-debuginfo-3.10.0.1-54.6.3
gdm-debugsource-3.10.0.1-54.6.3
libgdm1-3.10.0.1-54.6.3
libgdm1-debuginfo-3.10.0.1-54.6.3
typelib-1_0-Gdm-1_0-3.10.0.1-54.6.3

- SUSE Linux Enterprise Server 12-SP3 (noarch):

gdm-lang-3.10.0.1-54.6.3
gdmflexiserver-3.10.0.1-54.6.3

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

gdm-3.10.0.1-54.6.3
gdm-debuginfo-3.10.0.1-54.6.3
gdm-debugsource-3.10.0.1-54.6.3
libgdm1-3.10.0.1-54.6.3
libgdm1-debuginfo-3.10.0.1-54.6.3
typelib-1_0-Gdm-1_0-3.10.0.1-54.6.3

- SUSE Linux Enterprise Desktop 12-SP3 (noarch):

gdm-lang-3.10.0.1-54.6.3
gdmflexiserver-3.10.0.1-54.6.3


References:

https://www.suse.com/security/cve/CVE-2018-14424.html
https://bugzilla.suse.com/1103737

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung