Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in xen
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in xen
ID: FEDORA-2018-683dfde81a
Distribution: Fedora
Plattformen: Fedora 28
Datum: Do, 30. August 2018, 07:16
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-3646
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15468
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15470
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15469
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-3620
Applikationen: Xen

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2018-683dfde81a
2018-08-30 04:50:15.759291
-------------------------------------------------------------------------------
-

Name : xen
Product : Fedora 28
Version : 4.10.1
Release : 6.fc28
URL : http://xen.org/
Summary : Xen is a virtual machine monitor
Description :
This package contains the XenD daemon and xm command line
tools, needed to manage virtual machines running under the
Xen hypervisor

-------------------------------------------------------------------------------
-
Update Information:

L1 Terminal Fault speculative side channel patch bundle [XSA-273,
CVE-2018-3620,
CVE-2018-3646] drop patches also in the bundle, which also includes Use of v2
grant tables may cause crash on ARM [XSA-268] (#1616081) x86: Incorrect
MSR_DEBUGCTL handling lets guests enable BTS [XSA-269] (#1616077) oxenstored
does not apply quota-maxentity [XSA-272] (#1616080)
-------------------------------------------------------------------------------
-
ChangeLog:

* Wed Aug 15 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-6
- L1 Terminal Fault speculative side channel patch bundle [XSA-273,
CVE-2018-3620, CVE-2018-3646]
drop patches also in the bundle, which also includes
Use of v2 grant tables may cause crash on ARM [XSA-268] (#1616081)
x86: Incorrect MSR_DEBUGCTL handling lets guests enable BTS [XSA-269]
(#1616077)
oxenstored does not apply quota-maxentity [XSA-272] (#1616080)
* Wed Jun 27 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-5
- preemption checks bypassed in x86 PV MM handling [XSA-264, CVE-2018-12891]
(#1595959)
- x86: #DB exception safety check can be triggered by a guest [XSA-265,
CVE-2018-12893] (#1595958)
- libxl fails to honour readonly flag on HVM emulated SCSI disks [XSA-266,
CVE-2018-12892] (#1595957)
* Fri Jun 15 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-4
- Speculative register leakage from lazy FPU context switching
[XSA-267, CVE-2018-3665]
- fix for change in iasl output
* Tue May 22 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-3
- Speculative Store Bypass [XSA-263, CVE-2018-3639]
(with extra patches so it applies cleanly)
* Tue May 8 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-2
- x86: mishandling of debug exceptions [XSA-260, CVE-2018-8897]
- x86 vHPET interrupt injection errors [XSA-261, CVE-2018-10982] (#1576089)
- qemu may drive Xen into unbounded loop [XSA-262, CVE-2018-10981] (#1576680)
* Thu May 3 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-1
- update to xen-4.10.1
adjust xen.use.fedora.ipxe.patch and xen.fedora.efi.build.patch
remove patches for issues now fixed upstream
package /usr/lib/debug/usr/lib/xen/boot/xen-shim-syms
* Wed Apr 25 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.0-9
- Information leak via crafted user-supplied CDROM [XSA-258, CVE-2018-10472]
(#1571867)
- x86: PV guest may crash Xen with XPTI [XSA-259, CVE-2018-10471] (#1571878)
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1610543 - CVE-2018-15469 xen: Use of v2 grant tables may cause
crash on ARM (XSA-268)
https://bugzilla.redhat.com/show_bug.cgi?id=1610543
[ 2 ] Bug #1610548 - CVE-2018-15468 xen: x86 Incorrect MSR_DEBUGCTL handling
lets guests enable BTS (XSA-269)
https://bugzilla.redhat.com/show_bug.cgi?id=1610548
[ 3 ] Bug #1610552 - CVE-2018-15470 xen: oxenstored does not apply
quota-maxentity (XSA-272)
https://bugzilla.redhat.com/show_bug.cgi?id=1610552
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2018-683dfde81a' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung