Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in libx11
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in libx11
ID: USN-3758-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS
Datum: Do, 30. August 2018, 23:55
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14600
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-7942
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14599
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-7943
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14598
Applikationen: libx11

Originalnachricht


--===============7590166709133163856==
Content-Type: multipart/signed; micalg="pgp-sha256";
protocol="application/pgp-signature";
boundary="=-WNo2lYrC8+x7MAGcAn32"


--=-WNo2lYrC8+x7MAGcAn32
Content-Type: text/plain; charset="UTF-8
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3758-1
August 30, 2018

libx11 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in libx11.

Software Description:
- libx11: X11 client-side library

Details:

Tobias Stoeckmann discovered that libx11 incorrectly handled certain
images. An attacker could possibly use this issue to access sensitive
information (CVE-2016-7942)

Tobias Stoeckmann discovered that libx11 incorrectly handled certain
inputs. An attacker could possibly use this issue to access sensitive
information. (CVE-2016-7943)

It was discovered that libx11 incorrectly handled certain inputs.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2018-14598, CVE-2018-14599, CVE-2018-14600)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
libx11-6 2:1.6.4-3ubuntu0.1
libx11-dev 2:1.6.4-3ubuntu0.1

Ubuntu 16.04 LTS:
libx11-6 2:1.6.3-1ubuntu2.1
libx11-dev 2:1.6.3-1ubuntu2.1

Ubuntu 14.04 LTS:
libx11-6 2:1.6.2-1ubuntu2.1
libx11-dev 2:1.6.2-1ubuntu2.1

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3758-1
CVE-2016-7942, CVE-2016-7943, CVE-2018-14598, CVE-2018-14599,
CVE-2018-14600

Package Information:
https://launchpad.net/ubuntu/+source/libx11/2:1.6.4-3ubuntu0.1
https://launchpad.net/ubuntu/+source/libx11/2:1.6.3-1ubuntu2.1
https://launchpad.net/ubuntu/+source/libx11/2:1.6.2-1ubuntu2.1
--=-WNo2lYrC8+x7MAGcAn32
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAABCAAGBQJbiD9+AAoJEEW851uECx9pGPYP/10sQxGuie8+/pLF8/Ts6W5r
z7p+YB7SNgq7VzgvkQFf3o12iF1TvTC+n+iALX1LPlKi0WNv6YAmoumv0w2cfZtB
2FkqDu8syn3BGbrxbAC34OnEIkYaG9x7Mcq71lrJKrNii7HHgiuojYk/lQbP+XXr
48yZo1SycstOHkq1zIN6qdCP9vkkAUb8csC/bu7RT/ubnhDp9PCNeJZBY4U7EZHF
OgK4exajrDMFm62eO9nA/X1Hy/6v490dV4wUG9p7nNTn2UQ5P9b26gYUHAggIbnu
dixMcFcjaP78QJY+tveE1YCLtK1RXfY4CpKwAHmvcmo0NJgaEh+SbfD8+pdm40wa
19SeBSU5s/XHmLEgZBbquo9xOysLT90idrWyOPL3DZoaYvLe71wn0thLhskbE+25
ujNXL70rV/ccHqKX48GPmeQENlsAo54983YuAj0BLKC/VbnJqjRro8i8rQEeUSKd
m69dlRhKjucZgVr9oBnrx5mzJN/m/dtlhFbj50lUqIwYNHgwlkEZ8WWUC8D4s7/q
mzLs6HhwSnZzUx7fRfZgYZo0YiHmX+p42+qsyJ8/eYrP0tuz8SPXMMZXA8ZknIDx
m2OPM6kGRmO3cUqBGBECXAUvhgryh0O6mwyJRMeRZe/J+4BfOhQNXhmj0D2lFb5O
1z2+qPCx7Bwa8fqXMK3Z
=l0q4
-----END PGP SIGNATURE-----

--=-WNo2lYrC8+x7MAGcAn32--



--===============7590166709133163856==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============7590166709133163856==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung