Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in nodejs4
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in nodejs4
ID: openSUSE-SU-2018:2667-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Sa, 8. September 2018, 21:34
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-0732
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12115
Applikationen: node.js

Originalnachricht

   openSUSE Security Update: Security update for nodejs4
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2667-1
Rating: moderate
References: #1082318 #1091764 #1097158 #1097748 #1105019

Cross-References: CVE-2018-0732 CVE-2018-12115
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves two vulnerabilities and has three
fixes is now available.

Description:

This update for nodejs4 fixes the following issues:

Security issues fixed:

- CVE-2018-12115: Fixed an out-of-bounds memory write in Buffer that could
be used to write to memory outside of a Buffer's memory space buffer
(bsc#1105019)
- Upgrade to OpenSSL 1.0.2p, which fixed:
- CVE-2018-0732: Client denial-of-service due to large DH parameter
(bsc#1097158)
- ECDSA key extraction via local side-channel

Other changes made:

- Recommend same major version npm package (bsc#1097748)
- Use absolute paths in executable shebang lines
- Fix building with ICU61.1 (bsc#1091764)
- Install license with %license, not %doc (bsc#1082318)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-991=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

nodejs4-4.9.1-17.1
nodejs4-debuginfo-4.9.1-17.1
nodejs4-debugsource-4.9.1-17.1
nodejs4-devel-4.9.1-17.1
npm4-4.9.1-17.1

- openSUSE Leap 42.3 (noarch):

nodejs4-docs-4.9.1-17.1


References:

https://www.suse.com/security/cve/CVE-2018-0732.html
https://www.suse.com/security/cve/CVE-2018-12115.html
https://bugzilla.suse.com/1082318
https://bugzilla.suse.com/1091764
https://bugzilla.suse.com/1097158
https://bugzilla.suse.com/1097748
https://bugzilla.suse.com/1105019

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung