Login
Newsletter
Werbung

Sicherheit: Denial of Service in tomcat
Aktuelle Meldungen Distributionen
Name: Denial of Service in tomcat
ID: RHSA-2018:2701-01
Distribution: Red Hat
Plattformen: Red Hat JBoss Web Server
Datum: Mi, 12. September 2018, 19:25
Referenzen: https://access.redhat.com/security/cve/CVE-2018-1336
Applikationen: Apache Tomcat

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat JBoss Web Server 3.1.0 Service Pack 5
security and bug fix update
Advisory ID: RHSA-2018:2701-01
Product: Red Hat JBoss Web Server
Advisory URL: https://access.redhat.com/errata/RHSA-2018:2701
Issue date: 2018-09-12
CVE Names: CVE-2018-1336
=====================================================================

1. Summary:

An update is now available for Red Hat JBoss Web Server 3.1 for RHEL 6 and
Red Hat JBoss Web Server 3.1 for RHEL 7.

Red Hat Product Security has rated this release as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat JBoss Web Server 3.1 for RHEL 6 - noarch
Red Hat JBoss Web Server 3.1 for RHEL 7 - noarch

3. Description:

Red Hat JBoss Web Server is a fully integrated and certified set of
components for hosting Java web applications. It is comprised of the Apache
HTTP Server, the Apache Tomcat Servlet container, Apache Tomcat Connector
(mod_jk), JBoss HTTP Connector (mod_cluster), Hibernate, and the Tomcat
Native library.

This release of Red Hat JBoss Web Server 3.1 Service Pack 5 serves as a
replacement for Red Hat JBoss Web Server 3.1, and includes bug fixes, which
are documented in the Release Notes document linked to in the References.

Security Fix(es):

* tomcat: A bug in the UTF-8 decoder can lead to DoS (CVE-2018-1336)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

Before applying the update, back up your existing Red Hat JBoss Web Server
installation (including all applications and configuration files).

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1607591 - CVE-2018-1336 tomcat: A bug in the UTF-8 decoder can lead to DoS

6. Package List:

Red Hat JBoss Web Server 3.1 for RHEL 6:

Source:
tomcat7-7.0.70-29.ep7.el6.src.rpm
tomcat8-8.0.36-33.ep7.el6.src.rpm

noarch:
tomcat7-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-admin-webapps-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-docs-webapp-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-el-2.2-api-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-javadoc-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-jsp-2.2-api-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-jsvc-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-lib-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-log4j-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-selinux-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-servlet-3.0-api-7.0.70-29.ep7.el6.noarch.rpm
tomcat7-webapps-7.0.70-29.ep7.el6.noarch.rpm
tomcat8-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-admin-webapps-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-docs-webapp-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-el-2.2-api-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-javadoc-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-jsp-2.3-api-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-jsvc-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-lib-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-log4j-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-selinux-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-servlet-3.1-api-8.0.36-33.ep7.el6.noarch.rpm
tomcat8-webapps-8.0.36-33.ep7.el6.noarch.rpm

Red Hat JBoss Web Server 3.1 for RHEL 7:

Source:
tomcat7-7.0.70-29.ep7.el7.src.rpm
tomcat8-8.0.36-33.ep7.el7.src.rpm

noarch:
tomcat7-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-admin-webapps-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-docs-webapp-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-el-2.2-api-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-javadoc-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-jsp-2.2-api-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-jsvc-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-lib-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-log4j-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-selinux-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-servlet-3.0-api-7.0.70-29.ep7.el7.noarch.rpm
tomcat7-webapps-7.0.70-29.ep7.el7.noarch.rpm
tomcat8-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-admin-webapps-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-docs-webapp-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-el-2.2-api-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-javadoc-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-jsp-2.3-api-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-jsvc-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-lib-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-log4j-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-selinux-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-servlet-3.1-api-8.0.36-33.ep7.el7.noarch.rpm
tomcat8-webapps-8.0.36-33.ep7.el7.noarch.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-1336
https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/documentation/en-us/red_hat_jboss_web_server/3.1/html-single/red_hat_jboss_web_server_3.1_service_pack_5_release_notes/index

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBW5lJYNzjgjWX9erEAQiDdg//T/GnkfyalnP6DlFlYfQs0eb0CJx/usGT
ZspIb8DvvCB/irKXx3Rlf3O/EGNAhRBeuuS39iBaKvYZB1WRhhUeeQzYXOeRQY8L
4SnIERYi8DH2aBnnix0IqCQHVjs7FZLdZjVviJxj58EElMkqUPc/aybcAJ25cD+N
nv/ndsqxbKWs3n2EkBDw+tKDJVgURG89cC40XIRHFT4xBP6/XsgHa0uaV9N+0/v+
DoyfblW87zJgKwtjgksPDPF9SzbMvS9I2W1UyaRfSErsi0CU0cIcGepyZ/18+N9+
ePkYhnahs6h+ynxeyGcYOOT7P6+zhoC/U/8UayjS58jN1z9tqjXtCtGbsJrpKzoH
EhsL6n8jeYsazOowxYfLwVvz1Fjlpg0wT+cCEuy2cKiVAXpg1S+6K8mEW5Uu4HCY
lEHYe8x6WzPDD1ZzKhOUOwwX1QOdXxVxLULc58pdmqNTSOxwEhBldoakfM3HOprO
q4q7GF7TUoLvzcCAZeQulZK/ZOxlRwSLEvSFbi9TD+Pl+7RLixgKNueRtHQ9DS3f
oMAicG6MGWdlomaHBJaaY48T9bc33qkjNMHV1ia/gA6Roua4TZvL0Jai7d3aZ8vT
As33034MVIujw3h9wlJbIS8o+R7bKbL4YvN38/jD3v9JROCgi278+X4GibkPCigZ
x4nvcTddZvU=
=gbtI
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung