Login
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in curl
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in curl
ID: openSUSE-SU-2018:2731-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 15. September 2018, 17:07
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14618
Applikationen: curl

Originalnachricht

   openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2731-1
Rating: moderate
References: #1086367 #1106019
Cross-References: CVE-2018-14618
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for curl fixes the following issues:

This security issue was fixed:

- CVE-2018-14618: Prevent integer overflow in the NTLM authentication code
(bsc#1106019)

This non-security issue was fixed:

- Use OPENSSL_config instead of CONF_modules_load_file() to avoid crashes
due to openssl engines conflicts (bsc#1086367)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1010=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

curl-7.60.0-lp150.2.12.1
curl-debuginfo-7.60.0-lp150.2.12.1
curl-debugsource-7.60.0-lp150.2.12.1
curl-mini-7.60.0-lp150.2.12.1
curl-mini-debuginfo-7.60.0-lp150.2.12.1
curl-mini-debugsource-7.60.0-lp150.2.12.1
libcurl-devel-7.60.0-lp150.2.12.1
libcurl-mini-devel-7.60.0-lp150.2.12.1
libcurl4-7.60.0-lp150.2.12.1
libcurl4-debuginfo-7.60.0-lp150.2.12.1
libcurl4-mini-7.60.0-lp150.2.12.1
libcurl4-mini-debuginfo-7.60.0-lp150.2.12.1

- openSUSE Leap 15.0 (x86_64):

libcurl-devel-32bit-7.60.0-lp150.2.12.1
libcurl4-32bit-7.60.0-lp150.2.12.1
libcurl4-32bit-debuginfo-7.60.0-lp150.2.12.1


References:

https://www.suse.com/security/cve/CVE-2018-14618.html
https://bugzilla.suse.com/1086367
https://bugzilla.suse.com/1106019

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung