Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in nodejs8
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in nodejs8
ID: openSUSE-SU-2018:2855-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Di, 25. September 2018, 18:40
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-0732
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12115
Applikationen: node.js

Originalnachricht

   openSUSE Security Update: Security update for nodejs8
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2855-1
Rating: moderate
References: #1097158 #1097748 #1105019
Cross-References: CVE-2018-0732 CVE-2018-12115
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for nodejs8 to version 8.11.4 fixes the following issues:

Security issues fixed:

- CVE-2018-12115: Fixed an out-of-bounds memory write in Buffer that could
be used to write to memory outside of a Buffer's memory space buffer
(bsc#1105019)
- Upgrade to OpenSSL 1.0.2p, which fixed:
- CVE-2018-0732: Client denial-of-service due to large DH parameter
(bsc#1097158)
- ECDSA key extraction via local side-channel

Other changes made:

- Recommend same major version npm package (bsc#1097748)
- Fix parallel/test-tls-passphrase.js test to continue to function with
older versions of OpenSSL library.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1047=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

nodejs8-8.11.4-lp150.2.6.1
nodejs8-debuginfo-8.11.4-lp150.2.6.1
nodejs8-debugsource-8.11.4-lp150.2.6.1
nodejs8-devel-8.11.4-lp150.2.6.1
npm8-8.11.4-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

nodejs8-docs-8.11.4-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-0732.html
https://www.suse.com/security/cve/CVE-2018-12115.html
https://bugzilla.suse.com/1097158
https://bugzilla.suse.com/1097748
https://bugzilla.suse.com/1105019

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung