Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in apache2
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in apache2
ID: openSUSE-SU-2018:2856-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Di, 25. September 2018, 18:43
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-8743
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4975
Applikationen: Apache

Originalnachricht

   openSUSE Security Update: Security update for apache2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2856-1
Rating: moderate
References: #1016715 #1104826
Cross-References: CVE-2016-4975 CVE-2016-8743
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for apache2 fixes the following issues:

Security issues fixed:

- CVE-2016-8743: Fixed liberal whitespace interpretation accepted from
requests and sent in response lines and headers. Accepting these
different behaviors represented a security concern when httpd
participates in any chain of proxies or interacts with back-end
application servers, either through mod_proxy or using conventional CGI
mechanisms, and may result in request smuggling, response splitting and
cache pollution. (bsc#1016715)
- CVE-2016-4975: Fixed possible CRLF injection allowing HTTP response
splitting attacks for sites which use mod_userdir. This issue was
mitigated by changes which prohibit CR or LF injection into the
"Location" or other outbound header key or value. (bsc#1104826)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1046=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

apache2-2.4.23-28.1
apache2-debuginfo-2.4.23-28.1
apache2-debugsource-2.4.23-28.1
apache2-devel-2.4.23-28.1
apache2-event-2.4.23-28.1
apache2-event-debuginfo-2.4.23-28.1
apache2-example-pages-2.4.23-28.1
apache2-prefork-2.4.23-28.1
apache2-prefork-debuginfo-2.4.23-28.1
apache2-utils-2.4.23-28.1
apache2-utils-debuginfo-2.4.23-28.1
apache2-worker-2.4.23-28.1
apache2-worker-debuginfo-2.4.23-28.1

- openSUSE Leap 42.3 (noarch):

apache2-doc-2.4.23-28.1


References:

https://www.suse.com/security/cve/CVE-2016-4975.html
https://www.suse.com/security/cve/CVE-2016-8743.html
https://bugzilla.suse.com/1016715
https://bugzilla.suse.com/1104826

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung