Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in ant
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in ant
ID: openSUSE-SU-2018:2895-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Do, 27. September 2018, 23:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10886
Applikationen: Apache Ant

Originalnachricht

   openSUSE Security Update: Security update for ant
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2895-1
Rating: moderate
References: #1100053
Cross-References: CVE-2018-10886
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for ant fixes the following issues:

Security issue fixed:

- CVE-2018-10886: Fixed a path traversal vulnerability in malformed zip
file paths, which allowed arbitrary file writes and could potentially
lead to code execution (bsc#1100053)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1057=1



Package List:

- openSUSE Leap 15.0 (noarch):

ant-1.9.10-lp150.2.3.1
ant-antlr-1.9.10-lp150.2.3.1
ant-apache-bcel-1.9.10-lp150.2.3.1
ant-apache-bsf-1.9.10-lp150.2.3.1
ant-apache-log4j-1.9.10-lp150.2.3.1
ant-apache-oro-1.9.10-lp150.2.3.1
ant-apache-regexp-1.9.10-lp150.2.3.1
ant-apache-resolver-1.9.10-lp150.2.3.1
ant-apache-xalan2-1.9.10-lp150.2.3.1
ant-commons-logging-1.9.10-lp150.2.3.1
ant-commons-net-1.9.10-lp150.2.3.1
ant-javamail-1.9.10-lp150.2.3.1
ant-jdepend-1.9.10-lp150.2.3.1
ant-jmf-1.9.10-lp150.2.3.1
ant-jsch-1.9.10-lp150.2.3.1
ant-junit-1.9.10-lp150.2.3.1
ant-manual-1.9.10-lp150.2.3.1
ant-scripts-1.9.10-lp150.2.3.1
ant-swing-1.9.10-lp150.2.3.1
ant-testutil-1.9.10-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-10886.html
https://bugzilla.suse.com/1100053

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung