Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in openssl
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in openssl
ID: openSUSE-SU-2018:2957-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: So, 30. September 2018, 20:50
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-0737
Applikationen: OpenSSL

Originalnachricht

   openSUSE Security Update: Security update for openssl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2957-1
Rating: moderate
References: #1089039 #1101246 #1101470 #1104789 #1106197
#997043
Cross-References: CVE-2018-0737
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has 5 fixes is
now available.

Description:

This update for openssl fixes the following issues:

These security issues were fixed:

- Prevent One&Done side-channel attack on RSA that allowed physically
near
attackers to use EM emanations to recover information (bsc#1104789)
- CVE-2018-0737: The RSA Key generation algorithm has been shown to be
vulnerable to a cache timing side channel attack. An attacker with
sufficient access to mount cache timing attacks during the RSA key
generation process could have recovered the private key (bsc#1089039)

These non-security issues were fixed:

- Add openssl(cli) Provide so the packages that require the openssl binary
can require this instead of the new openssl meta package (bsc#1101470)
- Fixed path to the engines which are under /lib64 on SLE-12 (bsc#1101246,
bsc#997043)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1091=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libopenssl-devel-1.0.2j-29.1
libopenssl1_0_0-1.0.2j-29.1
libopenssl1_0_0-debuginfo-1.0.2j-29.1
libopenssl1_0_0-hmac-1.0.2j-29.1
openssl-1.0.2j-29.1
openssl-cavs-1.0.2j-29.1
openssl-cavs-debuginfo-1.0.2j-29.1
openssl-debuginfo-1.0.2j-29.1
openssl-debugsource-1.0.2j-29.1

- openSUSE Leap 42.3 (noarch):

openssl-doc-1.0.2j-29.1

- openSUSE Leap 42.3 (x86_64):

libopenssl-devel-32bit-1.0.2j-29.1
libopenssl1_0_0-32bit-1.0.2j-29.1
libopenssl1_0_0-debuginfo-32bit-1.0.2j-29.1
libopenssl1_0_0-hmac-32bit-1.0.2j-29.1


References:

https://www.suse.com/security/cve/CVE-2018-0737.html
https://bugzilla.suse.com/1089039
https://bugzilla.suse.com/1101246
https://bugzilla.suse.com/1101470
https://bugzilla.suse.com/1104789
https://bugzilla.suse.com/1106197
https://bugzilla.suse.com/997043

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung