Login
Newsletter
Werbung

Sicherheit: Denial of Service in bitcoin
Aktuelle Meldungen Distributionen
Name: Denial of Service in bitcoin
ID: openSUSE-SU-2018:3001-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3, SUSE openSUSE Leap 15.0, SUSE openSUSE Backports SLE-15
Datum: Do, 4. Oktober 2018, 15:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17144
Applikationen: bitcoin

Originalnachricht

   openSUSE Security Update: Security update for bitcoin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3001-1
Rating: important
References: #1108992
Cross-References: CVE-2018-17144
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for bitcoin to version 0.16.3 fixes the following issues:

- CVE-2018-17144: Prevent remote denial of service (application crash)
exploitable by miners via duplicate input (bsc#1108992).

For additional changes please check the changelog.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1098=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1098=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2018-1098=1



Package List:

- openSUSE Leap 42.3 (x86_64):

bitcoin-debugsource-0.16.3-7.3.1
bitcoin-qt5-0.16.3-7.3.1
bitcoin-qt5-debuginfo-0.16.3-7.3.1
bitcoin-test-0.16.3-7.3.1
bitcoin-test-debuginfo-0.16.3-7.3.1
bitcoin-utils-0.16.3-7.3.1
bitcoin-utils-debuginfo-0.16.3-7.3.1
bitcoind-0.16.3-7.3.1
bitcoind-debuginfo-0.16.3-7.3.1
libbitcoinconsensus-devel-0.16.3-7.3.1
libbitcoinconsensus0-0.16.3-7.3.1
libbitcoinconsensus0-debuginfo-0.16.3-7.3.1

- openSUSE Leap 15.0 (x86_64):

bitcoin-debuginfo-0.16.3-lp150.2.3.1
bitcoin-debugsource-0.16.3-lp150.2.3.1
bitcoin-qt5-0.16.3-lp150.2.3.1
bitcoin-qt5-debuginfo-0.16.3-lp150.2.3.1
bitcoin-test-0.16.3-lp150.2.3.1
bitcoin-test-debuginfo-0.16.3-lp150.2.3.1
bitcoin-utils-0.16.3-lp150.2.3.1
bitcoin-utils-debuginfo-0.16.3-lp150.2.3.1
bitcoind-0.16.3-lp150.2.3.1
bitcoind-debuginfo-0.16.3-lp150.2.3.1
libbitcoinconsensus-devel-0.16.3-lp150.2.3.1
libbitcoinconsensus0-0.16.3-lp150.2.3.1
libbitcoinconsensus0-debuginfo-0.16.3-lp150.2.3.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

bitcoin-qt5-0.16.3-bp150.3.3.1
bitcoin-test-0.16.3-bp150.3.3.1
bitcoin-utils-0.16.3-bp150.3.3.1
bitcoind-0.16.3-bp150.3.3.1
libbitcoinconsensus-devel-0.16.3-bp150.3.3.1
libbitcoinconsensus0-0.16.3-bp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-17144.html
https://bugzilla.suse.com/1108992

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung