Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in ImageMagick
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in ImageMagick
ID: 201810-04
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 7. Oktober 2018, 10:37
Referenzen: https://www.kb.cert.org/vuls/id/332928
Applikationen: ImageMagick

Originalnachricht


--dWYAkE0V1FpFQHQ3
Content-Type: text/plain; charset=utf-8
Content-Disposition: inlin
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201810-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: ImageMagick: Security hardening
Date: October 06, 2018
Bugs: #664236
ID: 201810-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Due to multiple vulnerabilities in various coders used by ImageMagick,
Gentoo Linux now installs a policy.xml file which will restrict coder
usage by default.

Background
==========

ImageMagick is a collection of tools and libraries for many image
formats.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/imagemagick < 6.9.10.10-r1 >= 6.9.10.10-r1
< 7.0.8.10-r1 >= 7.0.8.10-r1

Description
===========

If you process an image with ImageMagick and don't validate the file
before (e.g. check magic byte), ImageMagick will call any coders found
in the given file. So if ImageMagick will find Ghostscript for example,
it will call Ghostscript.

Due to multiple -dSAFER sandbox bypass vulnerabilities in Ghostscript,
this can lead to arbitrary code execution.

To mitigate this problem we install a policy.xml file by default which
will disable PS, EPS, PDF, and XPS coders.

Impact
======

A remote attacker, by enticing a user to process a specially crafted
image file, could execute arbitrary code with the privileges of the
process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ImageMagick 6 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=media-gfx/imagemagick-6.9.10.10-r1"

All ImageMagick 7 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=media-gfx/imagemagick-7.0.8.10-r1"

References
==========

[ 1 ] Ghostscript contains multiple -dSAFER sandbox bypass
vulnerabilities (VU#332928)
https://www.kb.cert.org/vuls/id/332928

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201810-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

--dWYAkE0V1FpFQHQ3
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAlu47IsACgkQpRQw84X1
dt1JyAf/YuOSep3SpQZ8tInGOJ9K42zg0B3hwNWixEpiFn13f++Q+GbGVglKHt4C
qRxMlk1VOdgntZDIrWj+fIRUCNtYOiWLPbX50Qt93hRpuFhC5Q3K+u/fhB5f3R4b
0Gfgf/8LgmmIemEeGJNEDWgDcvlYi7kBq0hEk10bK+OrATZfRMD9rINKcmZfI607
9O+t0QBukWFuQiOX3xY5rclolBd3vxm7PhI3krLhaXgy1dRL1J1s4/Z+QF/C+VgD
5u5NM1pjPeys/wYU1yS9LPqvMA1KTR5dhwq9gVkwPf6c1EGajxQhrpUUBV+6KyPS
di8ckQ2hLN1gDpeQ+azH/IdvSBBAIA==
=oOg9
-----END PGP SIGNATURE-----

--dWYAkE0V1FpFQHQ3--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung