Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in libxml2
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in libxml2
ID: openSUSE-SU-2018:3107-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Fr, 12. Oktober 2018, 12:33
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9251
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14567
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14404
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18258
Applikationen: libxml2

Originalnachricht

   openSUSE Security Update: Security update for libxml2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3107-1
Rating: moderate
References: #1088279 #1088601 #1102046 #1105166
Cross-References: CVE-2017-18258 CVE-2018-14404 CVE-2018-14567
CVE-2018-9251
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for libxml2 fixes the following security issues:

- CVE-2018-9251: The xz_decomp function allowed remote attackers to cause
a denial of service (infinite loop) via a crafted XML file that triggers
LZMA_MEMLIMIT_ERROR, as demonstrated by xmllint (bsc#1088279).
- CVE-2018-14567: Prevent denial of service (infinite loop) via a crafted
XML file that triggers LZMA_MEMLIMIT_ERROR, as demonstrated by xmllint
(bsc#1105166).
- CVE-2018-14404: Prevent NULL pointer dereference in the
xmlXPathCompOpEval() function when parsing an invalid XPath expression
in the XPATH_OP_AND or XPATH_OP_OR case leading to a denial of service
attack (bsc#1102046).
- CVE-2017-18258: The xz_head function allowed remote attackers to cause a
denial of service (memory consumption) via a crafted LZMA file, because
the decoder functionality did not restrict memory usage to what is
required for a legitimate file (bsc#1088601).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1149=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libxml2-2-2.9.4-18.1
libxml2-2-debuginfo-2.9.4-18.1
libxml2-debugsource-2.9.4-18.1
libxml2-devel-2.9.4-18.1
libxml2-tools-2.9.4-18.1
libxml2-tools-debuginfo-2.9.4-18.1
python-libxml2-2.9.4-18.1
python-libxml2-debuginfo-2.9.4-18.1
python-libxml2-debugsource-2.9.4-18.1

- openSUSE Leap 42.3 (x86_64):

libxml2-2-32bit-2.9.4-18.1
libxml2-2-debuginfo-32bit-2.9.4-18.1
libxml2-devel-32bit-2.9.4-18.1

- openSUSE Leap 42.3 (noarch):

libxml2-doc-2.9.4-18.1


References:

https://www.suse.com/security/cve/CVE-2017-18258.html
https://www.suse.com/security/cve/CVE-2018-14404.html
https://www.suse.com/security/cve/CVE-2018-14567.html
https://www.suse.com/security/cve/CVE-2018-9251.html
https://bugzilla.suse.com/1088279
https://bugzilla.suse.com/1088601
https://bugzilla.suse.com/1102046
https://bugzilla.suse.com/1105166

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung