Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in git
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in git
ID: openSUSE-SU-2018:3178-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mi, 17. Oktober 2018, 07:44
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17456
Applikationen: Git

Originalnachricht

   openSUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3178-1
Rating: important
References: #1110949
Cross-References: CVE-2018-17456
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for git fixes the following issues:

- CVE-2018-17456: Git allowed remote code execution during processing of a
recursive "git clone" of a superproject if a .gitmodules file has
a URL
field beginning with a '-' character. (boo#1110949).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1177=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

git-2.16.4-lp150.2.6.1
git-arch-2.16.4-lp150.2.6.1
git-core-2.16.4-lp150.2.6.1
git-core-debuginfo-2.16.4-lp150.2.6.1
git-credential-gnome-keyring-2.16.4-lp150.2.6.1
git-credential-gnome-keyring-debuginfo-2.16.4-lp150.2.6.1
git-credential-libsecret-2.16.4-lp150.2.6.1
git-credential-libsecret-debuginfo-2.16.4-lp150.2.6.1
git-cvs-2.16.4-lp150.2.6.1
git-daemon-2.16.4-lp150.2.6.1
git-daemon-debuginfo-2.16.4-lp150.2.6.1
git-debuginfo-2.16.4-lp150.2.6.1
git-debugsource-2.16.4-lp150.2.6.1
git-email-2.16.4-lp150.2.6.1
git-gui-2.16.4-lp150.2.6.1
git-p4-2.16.4-lp150.2.6.1
git-svn-2.16.4-lp150.2.6.1
git-svn-debuginfo-2.16.4-lp150.2.6.1
git-web-2.16.4-lp150.2.6.1
gitk-2.16.4-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

git-doc-2.16.4-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-17456.html
https://bugzilla.suse.com/1110949

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung