Login
Newsletter
Werbung

Sicherheit: Mangelnde Eingabeprüfung in postgresql94
Aktuelle Meldungen Distributionen
Name: Mangelnde Eingabeprüfung in postgresql94
ID: SUSE-SU-2018:3287-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP4
Datum: Mo, 22. Oktober 2018, 18:37
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10915
Applikationen: PostgreSQL

Originalnachricht

   SUSE Security Update: Security update for postgresql94
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:3287-1
Rating: important
References: #1104199
Cross-References: CVE-2018-10915
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for postgresql94 fixes the following issues:

postgresql was updated to 9.4.19:

https://www.postgresql.org/docs/current/static/release-9-4-19.html
* CVE-2018-10915, bsc#1104199: Fix failure to reset libpq's state
fully
between connection attempts.

postgresql was updated to 9.4.18:

- https://www.postgresql.org/about/news/1851/
- https://www.postgresql.org/docs/current/static/release-9-4-18.html A
dump/restore is not required for those running 9.4.X. However, if the
function marking mistakes mentioned in the first changelog entry below
affect you, you will want to take steps to correct your database
catalogs.


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-postgresql94-13829=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-postgresql94-13829=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-postgresql94-13829=1



Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
s390x x86_64):

postgresql94-devel-9.4.19-0.23.19.1

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

libecpg6-9.4.19-0.23.19.1
libpq5-9.4.19-0.23.19.1
postgresql94-9.4.19-0.23.19.1
postgresql94-contrib-9.4.19-0.23.19.1
postgresql94-docs-9.4.19-0.23.19.1
postgresql94-server-9.4.19-0.23.19.1

- SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):

libpq5-32bit-9.4.19-0.23.19.1

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):

postgresql94-debuginfo-9.4.19-0.23.19.1
postgresql94-debugsource-9.4.19-0.23.19.1
postgresql94-libs-debuginfo-9.4.19-0.23.19.1
postgresql94-libs-debugsource-9.4.19-0.23.19.1


References:

https://www.suse.com/security/cve/CVE-2018-10915.html
https://bugzilla.suse.com/1104199

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung