Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in pam_pkcs11
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in pam_pkcs11
ID: openSUSE-SU-2018:3369-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mi, 24. Oktober 2018, 15:17
Referenzen: Keine Angabe
Applikationen: pam_pkcs11

Originalnachricht

   openSUSE Security Update: Security update for pam_pkcs11
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3369-1
Rating: moderate
References: #1049219 #1105012
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for pam_pkcs11 provides the following fixes:

Security issues fixed (bsc#1105012):

- Fixed a logic bug in pampkcs11.c, leading to an authentication replay
vulnerability
- Fixed a stack-based buffer overflow in opensshmapper.c
- Make sure memory is properly cleaned before invoking free()

Other changes:

- Add a systemd service file. (bsc#1049219)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1244=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

pam_pkcs11-0.6.8-13.3.1
pam_pkcs11-debuginfo-0.6.8-13.3.1
pam_pkcs11-debugsource-0.6.8-13.3.1

- openSUSE Leap 42.3 (x86_64):

pam_pkcs11-32bit-0.6.8-13.3.1
pam_pkcs11-debuginfo-32bit-0.6.8-13.3.1


References:

https://bugzilla.suse.com/1049219
https://bugzilla.suse.com/1105012

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung