Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in tiff
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in tiff
ID: openSUSE-SU-2018:3370-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mi, 24. Oktober 2018, 15:17
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17101
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10779
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16335
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17100
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17795
Applikationen: libtiff

Originalnachricht

   openSUSE Security Update: Security update for tiff
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3370-1
Rating: moderate
References: #1092480 #1106853 #1108627 #1108637 #1110358

Cross-References: CVE-2018-10779 CVE-2018-16335 CVE-2018-17100
CVE-2018-17101 CVE-2018-17795
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for tiff fixes the following issues:

Security issue fixed:

- CVE-2018-10779: TIFFWriteScanline in tif_write.c had a heap-based buffer
over-read, as demonstrated by bmp2tiff.(bsc#1092480)
- CVE-2018-17100: There is a int32 overflow in multiply_ms in
tools/ppm2tiff.c, which can cause a denial of service (crash) or
possibly have unspecified other impact via a crafted image file.
(bsc#1108637)
- CVE-2018-17101: There are two out-of-bounds writes in cpTags in
tools/tiff2bw.c and tools/pal2rgb.c, which can cause a denial of service
(application crash) or possibly have unspecified other impact via a
crafted image file. (bsc#1108627)
- CVE-2018-17795: The function t2p_write_pdf in tiff2pdf.c allowed remote
attackers to cause a denial of service (heap-based buffer overflow and
application crash) or possibly have unspecified other impact via a
crafted TIFF file, a similar issue to CVE-2017-9935. (bsc#1110358)
- CVE-2018-16335: newoffsets handling in ChopUpSingleUncompressedStrip in
tif_dirread.c allowed remote attackers to cause a denial of service
(heap-based buffer overflow and application crash) or possibly have
unspecified other impact via a crafted TIFF file, as demonstrated by
tiff2pdf. This is a different vulnerability than CVE-2018-15209.
(bsc#1106853)


This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1242=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libtiff-devel-4.0.9-lp150.4.6.1
libtiff5-4.0.9-lp150.4.6.1
libtiff5-debuginfo-4.0.9-lp150.4.6.1
tiff-4.0.9-lp150.4.6.1
tiff-debuginfo-4.0.9-lp150.4.6.1
tiff-debugsource-4.0.9-lp150.4.6.1

- openSUSE Leap 15.0 (x86_64):

libtiff-devel-32bit-4.0.9-lp150.4.6.1
libtiff5-32bit-4.0.9-lp150.4.6.1
libtiff5-32bit-debuginfo-4.0.9-lp150.4.6.1


References:

https://www.suse.com/security/cve/CVE-2018-10779.html
https://www.suse.com/security/cve/CVE-2018-16335.html
https://www.suse.com/security/cve/CVE-2018-17100.html
https://www.suse.com/security/cve/CVE-2018-17101.html
https://www.suse.com/security/cve/CVE-2018-17795.html
https://bugzilla.suse.com/1092480
https://bugzilla.suse.com/1106853
https://bugzilla.suse.com/1108627
https://bugzilla.suse.com/1108637
https://bugzilla.suse.com/1110358

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung