Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in rpm
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in rpm
ID: openSUSE-SU-2018:3373-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mi, 24. Oktober 2018, 15:21
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7501
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7500
Applikationen: RPM

Originalnachricht

   openSUSE Security Update: Security update for rpm
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3373-1
Rating: moderate
References: #1077692 #943457
Cross-References: CVE-2017-7500 CVE-2017-7501
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for rpm fixes the following issues:

These security issues were fixed:

- CVE-2017-7500: rpm did not properly handle RPM installations when a
destination path was a symbolic link to a directory, possibly changing
ownership and permissions of an arbitrary directory, and RPM files being
placed in an arbitrary destination (bsc#943457).
- CVE-2017-7501: rpm used temporary files with predictable names when
installing an RPM. An attacker with ability to write in a directory
where files will be installed could create symbolic links to an
arbitrary location and modify content, and possibly permissions to
arbitrary files, which could be used for denial of service or possibly
privilege escalation (bsc#943457)

This non-security issue was fixed:

- Use ksym-provides tool [bsc#1077692]

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1246=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

python3-rpm-4.11.2-14.10.1
python3-rpm-debuginfo-4.11.2-14.10.1
python3-rpm-debugsource-4.11.2-14.10.1
rpm-4.11.2-14.10.1
rpm-build-4.11.2-14.10.1
rpm-build-debuginfo-4.11.2-14.10.1
rpm-debuginfo-4.11.2-14.10.1
rpm-debugsource-4.11.2-14.10.1
rpm-devel-4.11.2-14.10.1
rpm-python-4.11.2-14.10.1
rpm-python-debuginfo-4.11.2-14.10.1
rpm-python-debugsource-4.11.2-14.10.1

- openSUSE Leap 42.3 (x86_64):

rpm-32bit-4.11.2-14.10.1
rpm-debuginfo-32bit-4.11.2-14.10.1


References:

https://www.suse.com/security/cve/CVE-2017-7500.html
https://www.suse.com/security/cve/CVE-2017-7501.html
https://bugzilla.suse.com/1077692
https://bugzilla.suse.com/943457

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung