Login
Newsletter
Werbung

Sicherheit: Denial of Service in net-snmp
Aktuelle Meldungen Distributionen
Name: Denial of Service in net-snmp
ID: openSUSE-SU-2018:3381-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mi, 24. Oktober 2018, 15:42
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18065
Applikationen: Net-SNMP

Originalnachricht

   openSUSE Security Update: Security update for net-snmp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3381-1
Rating: important
References: #1027353 #1081164 #1102775 #1111122
Cross-References: CVE-2018-18065
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:

This update for net-snmp fixes the following issues:

Security issues fixed:

- CVE-2018-18065: _set_key in agent/helpers/table_container.c had a NULL
Pointer Exception bug that can be used by an authenticated attacker to
remotely cause the instance to crash via a crafted UDP packet, resulting
in Denial of Service. (bsc#1111122)

Non-security issues fixed:

- swintst_rpm: Protect against unspecified Group name (bsc#1102775)
- Add tsm and tlstm MIBs and the USM security module. (bsc#1081164)
- Fix agentx freezing on timeout (bsc#1027353)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1243=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libsnmp30-5.7.3-lp150.6.3.1
libsnmp30-debuginfo-5.7.3-lp150.6.3.1
net-snmp-5.7.3-lp150.6.3.1
net-snmp-debuginfo-5.7.3-lp150.6.3.1
net-snmp-debugsource-5.7.3-lp150.6.3.1
net-snmp-devel-5.7.3-lp150.6.3.1
perl-SNMP-5.7.3-lp150.6.3.1
perl-SNMP-debuginfo-5.7.3-lp150.6.3.1
python2-net-snmp-5.7.3-lp150.6.3.1
python2-net-snmp-debuginfo-5.7.3-lp150.6.3.1
python3-net-snmp-5.7.3-lp150.6.3.1
python3-net-snmp-debuginfo-5.7.3-lp150.6.3.1
snmp-mibs-5.7.3-lp150.6.3.1

- openSUSE Leap 15.0 (x86_64):

libsnmp30-32bit-5.7.3-lp150.6.3.1
libsnmp30-32bit-debuginfo-5.7.3-lp150.6.3.1
net-snmp-devel-32bit-5.7.3-lp150.6.3.1


References:

https://www.suse.com/security/cve/CVE-2018-18065.html
https://bugzilla.suse.com/1027353
https://bugzilla.suse.com/1081164
https://bugzilla.suse.com/1102775
https://bugzilla.suse.com/1111122

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung