Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in lcms2
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in lcms2
ID: SUSE-SU-2018:3545-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP3, SUSE Linux Enterprise Server 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP3
Datum: Mo, 29. Oktober 2018, 17:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16435
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10165
Applikationen: Little CMS

Originalnachricht

   SUSE Security Update: Security update for lcms2
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:3545-1
Rating: moderate
References: #1021364 #1026649 #1026650 #1108813
Cross-References: CVE-2016-10165 CVE-2018-16435
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Desktop 12-SP3
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:

This update for lcms2 fixes the following security issues:

- CVE-2016-10165: The Type_MLU_Read function allowed remote attackers to
obtain sensitive information or cause a denial of service via an image
with a crafted ICC profile, which triggered an out-of-bounds heap read
(bsc#1021364).
- CVE-2018-16435: A integer overflow was fixed in the AllocateDataSet
function in cmscgats.c, that could lead to a heap-based buffer overflow
in the SetData function via a crafted file in the second argument to
cmsIT8LoadFromFile. (bsc#1108813)
- Ensure that LUT stages match channel count (bsc#1026649).
- sanitize input and output channels on MPE profiles (bsc#1026650).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2512=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2512=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-2512=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

lcms2-debuginfo-2.7-9.7.1
lcms2-debugsource-2.7-9.7.1
liblcms2-devel-2.7-9.7.1

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

lcms2-2.7-9.7.1
lcms2-debuginfo-2.7-9.7.1
lcms2-debugsource-2.7-9.7.1
liblcms2-2-2.7-9.7.1
liblcms2-2-debuginfo-2.7-9.7.1

- SUSE Linux Enterprise Server 12-SP3 (s390x x86_64):

liblcms2-2-32bit-2.7-9.7.1
liblcms2-2-debuginfo-32bit-2.7-9.7.1

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

lcms2-2.7-9.7.1
lcms2-debuginfo-2.7-9.7.1
lcms2-debugsource-2.7-9.7.1
liblcms2-2-2.7-9.7.1
liblcms2-2-32bit-2.7-9.7.1
liblcms2-2-debuginfo-2.7-9.7.1
liblcms2-2-debuginfo-32bit-2.7-9.7.1


References:

https://www.suse.com/security/cve/CVE-2016-10165.html
https://www.suse.com/security/cve/CVE-2018-16435.html
https://bugzilla.suse.com/1021364
https://bugzilla.suse.com/1026649
https://bugzilla.suse.com/1026650
https://bugzilla.suse.com/1108813

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung