Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in PostgreSQL
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in PostgreSQL
ID: 201810-08
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Di, 30. Oktober 2018, 23:00
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2018-1115
https://nvd.nist.gov/vuln/detail/CVE-2018-10925
https://nvd.nist.gov/vuln/detail/CVE-2018-10915
Applikationen: PostgreSQL

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--wa8ftu5z31pqUBupTlh6fFb5DRMfNuH7P
Content-Type: multipart/mixed;
boundary="Z28tntghRIdjrikKbeqwt2QeC0BpdoU3F";
protected-headers="v1"
From: Thomas Deutschmann <whissi@gentoo.org>
Reply-To: security@gentoo.org
To: gentoo-announce@lists.gentoo.org
Message-ID: <794e8227-2340-4895-4f13-029ab38694d7@gentoo.org>
Subject: [ GLSA 201810-08 ] PostgreSQL: Multiple vulnerabilities

--Z28tntghRIdjrikKbeqwt2QeC0BpdoU3F
Content-Type: text/plain; charset=utf-8
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201810-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: PostgreSQL: Multiple vulnerabilities
Date: October 30, 2018
Bugs: #603716, #603720, #664332
ID: 201810-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL, the worst which
could lead to privilege escalation.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql < 10.5 >= 9.3.24:9.3
>= 9.4.19:9.4
>= 9.5.14:9.5
>= 9.6.10:9.6
>= 10.5:10

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the referenced CVE identifiers for details.

In addition it was discovered that Gentoo's PostgreSQL installation
suffered from a privilege escalation vulnerability due to a runscript
which called OpenRC's checkpath() on a user controlled path and allowed
user running PostgreSQL to kill arbitrary processes via PID file
manipulation.

Impact
======

A remote attacker could bypass certain client-side connection security
features, read arbitrary server memory or alter certain data.

In addition, a local attacker could gain privileges or cause a Denial
of Service condition by killing arbitrary processes.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users up to 9.3 should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=dev-db/postgresql-9.3.24:9.3"

All PostgreSQL 9.4 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=dev-db/postgresql-9.4.19:9.4"

All PostgreSQL 9.5 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=dev-db/postgresql-9.5.14:9.5"

All PostgreSQL 9.6 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=dev-db/postgresql-9.6.10:9.6"

All PostgreSQL 10 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.5:10"

References
==========

[ 1 ] CVE-2018-10915
https://nvd.nist.gov/vuln/detail/CVE-2018-10915
[ 2 ] CVE-2018-10925
https://nvd.nist.gov/vuln/detail/CVE-2018-10925
[ 3 ] CVE-2018-1115
https://nvd.nist.gov/vuln/detail/CVE-2018-1115

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201810-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


--Z28tntghRIdjrikKbeqwt2QeC0BpdoU3F--

--wa8ftu5z31pqUBupTlh6fFb5DRMfNuH7P
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQGTBAEBCgB9FiEEExKRzo+LDXJgXHuURObr3Jv2BVkFAlvYxRNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDEz
MTI5MUNFOEY4QjBENzI2MDVDN0I5NDQ0RTZFQkRDOUJGNjA1NTkACgkQRObr3Jv2
BVmWDQf/dZ/oUuuF6Uy3jl0LR3dX901VYNG/qNfHrsV5MOrikM6y6dkrENTCWfFc
XEnzB3wInafCKClwED3RZGrHONol37Q7bQCQrijepA82PoNJV5iTujM/5T4KzFc9
2HaQkG5AuOEQHhnMYPhU0/9zSdb5sS2f1Q/UAJaNgcqJnc2aYwZQDg02KfpBfmwm
GpY5xYRfN4dxCivYWGWs74pbCzcUOwM8dAiihA9LJoYVLx+tL+A19fihdO52SkiX
7TB1O1Mkwhsx9ReHofxOQfriWQBZNtlk2NIW4XP2cTplPEWQ6MWx8SrL+SYXm6VS
eAW5mGcrF3hh3VBiCpUHG0X4r6jvog==
=egiM
-----END PGP SIGNATURE-----

--wa8ftu5z31pqUBupTlh6fFb5DRMfNuH7P--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung