Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in curl
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in curl
ID: openSUSE-SU-2018:3706-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 10. November 2018, 08:52
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16839
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16840
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16842
Applikationen: curl

Originalnachricht

   openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3706-1
Rating: moderate
References: #1112758 #1113660
Cross-References: CVE-2018-16839 CVE-2018-16840 CVE-2018-16842

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for curl fixes the following issues:

- CVE-2018-16839: A SASL password overflow via integer overflow was fixed
which could lead to crashes (bsc#1112758)
- CVE-2018-16840: A use-after-free in SASL handle close was fixed which
could lead to crashes (bsc#1112758)
- CVE-2018-16842: A Out-of-bounds Read in tool_msgs.c was fixed which
could lead to crashes (bsc#1113660)


This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1379=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

curl-7.60.0-lp150.2.15.1
curl-debuginfo-7.60.0-lp150.2.15.1
curl-debugsource-7.60.0-lp150.2.15.1
curl-mini-7.60.0-lp150.2.15.1
curl-mini-debuginfo-7.60.0-lp150.2.15.1
curl-mini-debugsource-7.60.0-lp150.2.15.1
libcurl-devel-7.60.0-lp150.2.15.1
libcurl-mini-devel-7.60.0-lp150.2.15.1
libcurl4-7.60.0-lp150.2.15.1
libcurl4-debuginfo-7.60.0-lp150.2.15.1
libcurl4-mini-7.60.0-lp150.2.15.1
libcurl4-mini-debuginfo-7.60.0-lp150.2.15.1

- openSUSE Leap 15.0 (x86_64):

libcurl-devel-32bit-7.60.0-lp150.2.15.1
libcurl4-32bit-7.60.0-lp150.2.15.1
libcurl4-32bit-debuginfo-7.60.0-lp150.2.15.1


References:

https://www.suse.com/security/cve/CVE-2018-16839.html
https://www.suse.com/security/cve/CVE-2018-16840.html
https://www.suse.com/security/cve/CVE-2018-16842.html
https://bugzilla.suse.com/1112758
https://bugzilla.suse.com/1113660

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung