Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in linux-ftpd-ssl
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in linux-ftpd-ssl
ID: DSA-896-1
Distribution: Debian
Plattformen: Debian sarge
Datum: Di, 15. November 2005, 07:49
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3524
Applikationen: NetKit

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 896-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
November 15th, 2005 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : linux-ftpd-ssl
Vulnerability : buffer overflow
Problem type : remote
Debian-specific: no
CVE ID : CVE-2005-3524
Debian Bug : 339074

A buffer overflow has been discovered in ftpd-ssl, a simple BSD FTP
server with SSL encryption support, that could lead to the execution
of arbitrary code.

The old stable distribution (woody) does not contain linux-ftpd-ssl
packages.

For the stable distribution (sarge) this problem has been fixed in
version 0.17.18+0.3-3sarge1

For the unstable distribution (sid) this problem will be fixed soon.

We recommend that you upgrade your ftpd-ssl package.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

linux-ftpd-ssl_0.17.18+0.3-3sarge1.dsc
Size/MD5 checksum: 640 f1999dff20d8e5c7bebbdf3ae08d9fbc
linux-ftpd-ssl_0.17.18+0.3-3sarge1.diff.gz
Size/MD5 checksum: 5157 bb183553291a97a7505dd3eba1ee28aa
linux-ftpd-ssl_0.17.18+0.3.orig.tar.gz
Size/MD5 checksum: 61388 525f77ad02c5593fa4c5cad9abc337b7

Alpha architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_alpha.deb
Size/MD5 checksum: 55448 5e4b657d47730305099a47ec2d8c84df

AMD64 architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_amd64.deb
Size/MD5 checksum: 50938 87ab0d101dc0e1c14d38888231abf11f

ARM architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_arm.deb
Size/MD5 checksum: 49478 d964f72a931cee99c560c1f348b9f733

Intel IA-32 architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_i386.deb
Size/MD5 checksum: 48598 6092dcf5345c383959b9b8b3a9d9b65f

Intel IA-64 architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_ia64.deb
Size/MD5 checksum: 65312 1f80c1ef53e6151a8d7df0ed0f2160cb

HP Precision architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_hppa.deb
Size/MD5 checksum: 53384 a247343d426eb9ecff838905432943d8

Motorola 680x0 architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_m68k.deb
Size/MD5 checksum: 46112 bedd079aca908ad7f31f7fb8fe0ecab7

Big endian MIPS architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_mips.deb
Size/MD5 checksum: 52262 fe07040d4d3db4fe2cd4e02c873131ee

Little endian MIPS architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_mipsel.deb
Size/MD5 checksum: 52074 5b1e112532d8b07ab278d036515d85d3

PowerPC architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_powerpc.deb
Size/MD5 checksum: 52050 bd09d568c4e634670c698dbe33cd4775

IBM S/390 architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_s390.deb
Size/MD5 checksum: 51862 d4cb84830ca8a631ed5e08344e286b18

Sun Sparc architecture:

ftpd-ssl_0.17.18+0.3-3sarge1_sparc.deb
Size/MD5 checksum: 48822 d47e7a161940d64f82a7edb87df7ff3e


These files will probably be moved into the stable distribution on
its next update.

-
---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDeYBNW5ql+IAeqTIRArSwAKCe8zIfwYxhHJfz2t1cOwzzMV6ZkgCfateo
Z5ly8y1GYmM/ndQxGGxJiFM=
=4CJ2
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung