Login
Newsletter
Werbung

Sicherheit: Ausführen von Code mit höheren Privilegien in PostgreSQL
Aktuelle Meldungen Distributionen
Name: Ausführen von Code mit höheren Privilegien in PostgreSQL
ID: 201811-24
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 30. November 2018, 12:07
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2018-16850
Applikationen: PostgreSQL

Originalnachricht


--H1spWtNR+x+ondvy
Content-Type: text/plain; charset=utf-8
Content-Disposition: inlin
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201811-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PostgreSQL: SQL injection
Date: November 30, 2018
Bugs: #670724
ID: 201811-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A SQL injection in PostgreSQL may allow attackers to execute arbitrary
SQL statements.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql *< 9.3.25 *>= 9.3.25
*< 9.4.20 *>= 9.4.20
*< 9.5.15 *>= 9.5.15
*< 9.6.11 *>= 9.6.11
*< 10.6 *>= 10.6
< 11.1 >= 11.1

Description
===========

A vulnerability was discovered in PostgreSQL's pg_upgrade and pg_dump.

Impact
======

An attacker, by enticing a user to process a specially crafted trigger
definition, can execute arbitrary SQL statements with superuser
privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.3.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.3.25"

All PostgreSQL 9.4.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.4.20"

All PostgreSQL 9.5.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.15"

All PostgreSQL 9.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.11"

All PostgreSQL 10.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.6"

All PostgreSQL 11.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.1"

References
==========

[ 1 ] CVE-2018-16850
https://nvd.nist.gov/vuln/detail/CVE-2018-16850

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201811-24

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

--H1spWtNR+x+ondvy
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAlwA+04ACgkQpRQw84X1
dt10fggAoBAwAQ3m0P6zQzZAZkGk+kXUv+kgSdBOl1ovXsB9EEhEE5aTxOJgiri6
5/YA4Wo7hdG5XXnatcFySUfhiFBZDROTW57xQASDsvXL7NOqjP8QmodJHhr9mmjZ
O4Jhhn99mN3dbt40N1aUg6mUyjJ9RrwnLPXQOVay/OU9iOZigIbnqX049ha7ycJE
zgbpE47pzSPBjkk2pXHWotEBH+9uqqz1cO5llFawn3hL05VyfFx+RfP/kTq/TKZC
BCY8V+fQxHfHHXso8oU69+pLxmgCY24R5vhGs/I0PejK3PW7Y3tlZEABataxHwtM
vH/StgFvDNfn2wc6z+h1KMYwpJo1vQ==
=WarM
-----END PGP SIGNATURE-----

--H1spWtNR+x+ondvy--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung