Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in git
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in git
ID: SUSE-SU-2018:4088-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-LTSS, SUSE OpenStack Cloud Magnum Orchestration 7, SUSE OpenStack Cloud 7, SUSE Linux Enterprise Server 12-SP1-LTSS, SUSE Linux Enterprise Server for SAP 12-SP2, SUSE Linux Enterprise Server 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP3, SUSE Enterprise Storage 4, SUSE CaaS Platform ALL, SUSE Linux Enterprise Server 12-SP2-LTSS, SUSE CaaS Platform 3.0, SUSE HPE Helion Openstack 8, SUSE OpenStack Cloud 8, SUSE Linux Enterprise Server 12-SP2-BCL
Datum: Do, 13. Dezember 2018, 07:17
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17456
Applikationen: Git

Originalnachricht

   SUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:4088-1
Rating: important
References: #1110949
Cross-References: CVE-2018-17456
Affected Products:
SUSE OpenStack Cloud 8
SUSE OpenStack Cloud 7
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Server for SAP 12-SP2
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP2-LTSS
SUSE Linux Enterprise Server 12-SP2-BCL
SUSE Linux Enterprise Server 12-SP1-LTSS
SUSE Linux Enterprise Server 12-LTSS
SUSE Enterprise Storage 4
SUSE CaaS Platform ALL
SUSE CaaS Platform 3.0
OpenStack Cloud Magnum Orchestration 7
HPE Helion Openstack 8
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for git fixes the following issue:

- CVE-2018-17456: Git allowed remote code execution during processing of a
recursive "git clone" of a superproject if a .gitmodules file has
a URL
field beginning with a '-' character. (boo#1110949).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud 8:

zypper in -t patch SUSE-OpenStack-Cloud-8-2018-2918=1

- SUSE OpenStack Cloud 7:

zypper in -t patch SUSE-OpenStack-Cloud-7-2018-2918=1

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2918=1

- SUSE Linux Enterprise Server for SAP 12-SP2:

zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-2918=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2918=1

- SUSE Linux Enterprise Server 12-SP2-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-2918=1

- SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-2918=1

- SUSE Linux Enterprise Server 12-SP1-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP1-2018-2918=1

- SUSE Linux Enterprise Server 12-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-2018-2918=1

- SUSE Enterprise Storage 4:

zypper in -t patch SUSE-Storage-4-2018-2918=1

- SUSE CaaS Platform ALL:

To install this update, use the SUSE CaaS Platform Velum dashboard.
It will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.

- SUSE CaaS Platform 3.0:

To install this update, use the SUSE CaaS Platform Velum dashboard.
It will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.

- OpenStack Cloud Magnum Orchestration 7:

zypper in -t patch
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2918=1

- HPE Helion Openstack 8:

zypper in -t patch HPE-Helion-OpenStack-8-2018-2918=1



Package List:

- SUSE OpenStack Cloud 8 (x86_64):

git-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE OpenStack Cloud 7 (s390x x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE OpenStack Cloud 7 (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

git-2.12.3-27.17.2
git-arch-2.12.3-27.17.2
git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-cvs-2.12.3-27.17.2
git-daemon-2.12.3-27.17.2
git-daemon-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2
git-email-2.12.3-27.17.2
git-gui-2.12.3-27.17.2
git-svn-2.12.3-27.17.2
git-svn-debuginfo-2.12.3-27.17.2
git-web-2.12.3-27.17.2
gitk-2.12.3-27.17.2

- SUSE Linux Enterprise Software Development Kit 12-SP3 (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server for SAP 12-SP2 (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP2-LTSS (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP2-BCL (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-SP1-LTSS (noarch):

git-doc-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Linux Enterprise Server 12-LTSS (noarch):

git-doc-2.12.3-27.17.2

- SUSE Enterprise Storage 4 (x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE Enterprise Storage 4 (noarch):

git-doc-2.12.3-27.17.2

- SUSE CaaS Platform ALL (x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- SUSE CaaS Platform 3.0 (x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- OpenStack Cloud Magnum Orchestration 7 (x86_64):

git-core-2.12.3-27.17.2
git-core-debuginfo-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2

- HPE Helion Openstack 8 (x86_64):

git-2.12.3-27.17.2
git-debugsource-2.12.3-27.17.2


References:

https://www.suse.com/security/cve/CVE-2018-17456.html
https://bugzilla.suse.com/1110949

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung